summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/chroot-run.sh3
-rw-r--r--job-cfg/edu-packages.yaml4
2 files changed, 5 insertions, 2 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index 858f46e0..813ef564 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -141,7 +141,8 @@ echo 'APT::Get::Assume-Yes "true";' > /etc/apt/apt.conf.d/23jenkins
apt-get install build-essential devscripts git
if [ "$1" = "gbp" ] ; then
apt-get install git-buildpackage
- git checkout debian
+ # either there is a debian branch or not
+ git checkout debian || echo "No debian branch exists, assuming packaging is in master branch."
fi
if [ -f debian/control ] ; then
cat debian/control
diff --git a/job-cfg/edu-packages.yaml b/job-cfg/edu-packages.yaml
index 62ec80a5..1c6f57e1 100644
--- a/job-cfg/edu-packages.yaml
+++ b/job-cfg/edu-packages.yaml
@@ -26,7 +26,7 @@
branches:
- master
builders:
- - shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} debuild -b -uc -us'
+ - shell: '{my_shell}'
triggers:
- pollscm:
cron: 'H/1 H/1 * * *'
@@ -43,6 +43,7 @@
- project:
name: edu-packages
my_distro: 'sid'
+ my_shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} debuild -b -uc -us'
my_url: 'git://git.debian.org/git/debian-edu/{my_package}.git'
my_package:
- 'debian-edu'
@@ -59,4 +60,5 @@
my_url: 'git://git.debian.org/git/pkg-remote/packages/{my_package}.git'
- 'italc':
my_url: 'git://git.debian.org/git/debian-edu/pkg-team/{my_package}.git'
+ my_shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} gbp buildpackage -uc -us'
jobs: ['{name}_{my_distro}_{my_package}']