summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--bin/g-i-installation.sh6
-rwxr-xr-xbin/maintainance.sh1
-rw-r--r--debian/control2
-rwxr-xr-xupdate_jdn.sh2
4 files changed, 6 insertions, 5 deletions
diff --git a/bin/g-i-installation.sh b/bin/g-i-installation.sh
index e4a9002a..454451b1 100644
--- a/bin/g-i-installation.sh
+++ b/bin/g-i-installation.sh
@@ -69,9 +69,10 @@ fi
#
# video
#
-VIDEOBITRATE=1200
VIDEOSIZE=1024x768
VIDEOBGCOLOR=gray10
+FRAMERATE=24 # this is the input framerate
+CONVERTOPTS="-gravity center -background $VIDEOBGCOLOR -extent $VIDEOSIZE"
fetch_if_newer() {
url="$2"
@@ -123,7 +124,7 @@ cleanup_all() {
#
echo "$(date) - Creating video now. This may take a while.'"
TMPFILE=$(mktemp)
- ffmpeg2theora --videobitrate $VIDEOBITRATE --no-upscaling snapshot_%06d.png --framerate 12 --max_size $VIDEOSIZE -o g-i-installation-$NAME.ogv > $TMPFILE 2>&1 || cat $TMPFILE
+ avconv -r $FRAMERATE snapshot_%06d.png g-i-installation-$NAME.webm > $TMPFILE 2>&1 || cat $TMPFILE
rm snapshot_??????.png $TMPFILE
# rename .bak files back to .png
if find . -name "*.png.bak" > /dev/null ; then
@@ -164,7 +165,6 @@ bootstrap_system() {
echo "Doing g-i installation test for $NAME now."
# qemu related variables (incl kernel+initrd) - display first, as we grep for this in the process list
QEMU_OPTS="-display vnc=$DISPLAY -no-shutdown -enable-kvm -cpu host"
- CONVERTOPTS="-gravity center -background $VIDEOBGCOLOR -extent $VIDEOSIZE"
if [ -n "$IMAGE" ] ; then
QEMU_OPTS="$QEMU_OPTS -cdrom $IMAGE -boot d"
case $NAME in
diff --git a/bin/maintainance.sh b/bin/maintainance.sh
index c9ed9db5..694c964a 100755
--- a/bin/maintainance.sh
+++ b/bin/maintainance.sh
@@ -157,6 +157,7 @@ else
report_disk_usage $1
report_filetype_usage $1 png
report_filetype_usage $1 ppm warn # FIXME: remove this check in 3 days (and add warn to pngs)
+ report_filetype_usage $1 ogv warn # FIXME: remove this check in 7 days
report_filetype_usage $1 bak warn
report_filetype_usage $1 raw warn
report_filetype_usage $1 iso warn
diff --git a/debian/control b/debian/control
index f3f7e9aa..2bebd81d 100644
--- a/debian/control
+++ b/debian/control
@@ -23,7 +23,7 @@ Description: Stuff to setup a jenkins.debian.net instance
Package: jenkins.debian.net-bin
Architecture: all
-Depends:, ${misc:Depends}, debootstrap, sudo, figlet, graphviz, mr, subversion, subversion-tools, vnstat, poxml, qemu, vncsnapshot, imagemagick, ffmpeg2theora, python-twisted, python-imaging, gocr, guestmount (>>1:1.18.1-1+deb7u1), schroot
+Depends:, ${misc:Depends}, debootstrap, sudo, figlet, graphviz, mr, subversion, subversion-tools, vnstat, poxml, qemu, vncsnapshot, imagemagick, libav-tools, python-twisted, python-imaging, gocr, guestmount (>>1:1.18.1-1+deb7u1), schroot
Description: Stuff to make jenkins.debian.net run and debug
Scripts and configuration files for running and debugging jobs run on
jenkins.debian.net.
diff --git a/update_jdn.sh b/update_jdn.sh
index fc7bb0b0..25206962 100755
--- a/update_jdn.sh
+++ b/update_jdn.sh
@@ -59,7 +59,7 @@ fi
#
sudo apt-get install vim screen less etckeeper moreutils curl mtr-tiny dstat devscripts bash-completion shorewall shorewall6 cron-apt apt-listchanges munin munin-plugins-extra calamaris visitors procmail libjson-rpc-perl libfile-touch-perl zutils ip2host pigz \
build-essential python-setuptools \
- debootstrap sudo figlet graphviz apache2 python-yaml python-pip mr subversion subversion-tools vnstat poxml vncsnapshot imagemagick ffmpeg2theora python-twisted python-imaging gocr guestmount schroot sqlite3\
+ debootstrap sudo figlet graphviz apache2 python-yaml python-pip mr subversion subversion-tools vnstat poxml vncsnapshot imagemagick libav-tools python-twisted python-imaging gocr guestmount schroot sqlite3\
unzip python-hachoir-metadata ghc python-rpy2 libsoap-lite-perl haveged
# debootstrap is affected by #766459 in wheezy
sudo apt-get install -t wheezy-backports qemu debootstrap