summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--TODO33
-rwxr-xr-xetc/munin/plugins/jenkins_builds3
-rwxr-xr-xetc/munin/plugins/jenkins_jobs3
-rwxr-xr-xupdate_jdn.sh2
4 files changed, 22 insertions, 19 deletions
diff --git a/TODO b/TODO
index 9eb7ece6..a3daeedf 100644
--- a/TODO
+++ b/TODO
@@ -8,17 +8,17 @@ About jenkins.debian.net
:Doctype: article
:Licence: GPLv2
-
== About jenkins.debian.net
-* http://jenkins.debian.net is pretty much work in progress, (hopefully) doing something useful since October 15th 2012
+* http://jenkins.debian.net is pretty much work in progress, (hopefully) doing something useful since October 15th 2012.
* Join #debian-qa on irc.debian.org to report bugs or give other feedback! Use debian-qa@lists.debian.org if you prefer mail.
-* git clone git://git.debian.org/git/users/holger/jenkins.debian.net.git
+* 'git clone git://git.debian.org/git/users/holger/jenkins.debian.net.git'
* (virtual) hardware sponsored by http://www.profitbricks.com - currently it's just a server, but in future there will be installation and tests clients started on demand as well.
* some stats are available at http://jenkins.debian.net/munin/jenkins-month.html
== More tests to be run
+
=== Tests for supporting d-i development:
* build the manual on every commit
@@ -64,32 +64,33 @@ About jenkins.debian.net
** properties: sidebar
* mail notifications (to where?)
* proper backup (=daily), see bottom of this document for what to backup
-* make job configuration visible to un-authenticated users
-* squid has problems with SO_FAIL
* split TODO and about.txt?
** use debian stylesheet for about.html
* proper git repo url, outside users/holger
+** http://anonscm.debian.org/gitweb/?p=users/holger/jenkins.debian.net.git
+* weekly runs of webcheck? but then, when to fail and become unstable?
* only trigger (=really run) jobs if available+used packages have changed (save packages in db and compare)
== Installed software that makes jenkins.debian.net run
* jenkins.debian.net runs Debian wheezy.
-* FIXME: how jenkins was installed + configured
-* needed packages are listed in update_jdn.sh and which will also make sure they are installed
-** update_jdn.sh is available in the git repo
-* package configuration is kept in git and deployed by update_jdn.sh as well
+* FIXME: describe how jenkins is installed + configured, basically put 'deb http://pkg.jenkins-ci.org/debian-stable binary/' into '/etc/apt/sources.list.d/jenkins.list' and `apt-get update`
+* needed packages are listed in 'update_jdn.sh' and which will also make sure they are installed
+** 'update_jdn.sh' is available in the git repo
+* package configuration is kept in that git repo and deployed by 'update_jdn.sh' as well.
=== Installing jenkins-job-builder
-* rebuild python-jenkinsapi from sid for wheezy
-* pip install python-jenkins
-* git clone https://github.com/openstack-ci/jenkins-job-builder ; cd jenkins-job-builder ; python setup.py install
+* rebuild python-jenkinsapi from sid for wheezy:
+* `pip install python-jenkins`
+* `git clone https://github.com/openstack-ci/jenkins-job-builder ; cd jenkins-job-builder ; python setup.py install`
+** actually https://github.com/h01ger/jenkins-job-builder is used atm.
=== Using jenkins-job-builder
-* then run 'cd /srv/jenkins/job-cfg ; jenkins-jobs update .' to update jobs
-* testing: 'cd /srv/jenkins/job-cfg ; rm test-output/ -r ; mkdir test-output ; jenkins-jobs test . -o test-output/ ; ls test-output/'
+* then run `cd /srv/jenkins/job-cfg ; jenkins-jobs update .` to update jobs
+* testing: `cd /srv/jenkins/job-cfg ; rm test-output/ -r ; mkdir test-output ; jenkins-jobs test . -o test-output/ ; ls test-output/`
== To backup
-* /etc/.git
-* /var/lib/jenkins/config.xml as well as its plugins
+* '/etc/.git'
+* '/var/lib/jenkins/config.xml' as well as its plugins
diff --git a/etc/munin/plugins/jenkins_builds b/etc/munin/plugins/jenkins_builds
index d0caa97b..bb2a4763 100755
--- a/etc/munin/plugins/jenkins_builds
+++ b/etc/munin/plugins/jenkins_builds
@@ -34,11 +34,12 @@ if [ "$1" = "config" ]; then
echo 'graph_title Jenkins Builds in the last 24h'
echo 'graph_args --base 1000 -l 0 '
echo 'graph_scale no'
+ echo 'graph_total total'
echo 'graph_vlabel Jenkins Builds per category in the last 24h'
echo 'graph_category jenkins'
for PREFIX in $JOB_PREFIXES ; do
echo "jenkins_builds_$PREFIX.label $PREFIX builds"
- echo "jenkins_builds_$PREFIX.draw AREA"
+ echo "jenkins_builds_$PREFIX.draw STACK"
#print_warning jenkins_builds_$PREFIX
#print_critical jenkins_builds_$PREFIX
done
diff --git a/etc/munin/plugins/jenkins_jobs b/etc/munin/plugins/jenkins_jobs
index 4b917b85..170a0333 100755
--- a/etc/munin/plugins/jenkins_jobs
+++ b/etc/munin/plugins/jenkins_jobs
@@ -34,11 +34,12 @@ if [ "$1" = "config" ]; then
echo 'graph_title Jenkins Jobs'
echo 'graph_args --base 1000 -l 0 '
echo 'graph_scale no'
+ echo 'graph_total total'
echo 'graph_vlabel Jenkins Jobs per category'
echo 'graph_category jenkins'
for PREFIX in $JOB_PREFIXES ; do
echo "jenkins_jobs_$PREFIX.label $PREFIX jobs"
- echo "jenkins_jobs_$PREFIX.draw AREA"
+ echo "jenkins_jobs_$PREFIX.draw STACK"
#print_warning jenkins_jobs_$PREFIX
#print_critical jenkins_jobs_$PREFIX
done
diff --git a/update_jdn.sh b/update_jdn.sh
index 1ceffff0..5c0ab998 100755
--- a/update_jdn.sh
+++ b/update_jdn.sh
@@ -25,7 +25,7 @@ done
#
sudo apt-get install vim screen less etckeeper curl mtr-tiny dstat devscripts bash-completion shorewall shorewall6 cron-apt apt-listchanges munin \
build-essential python-setuptools \
- debootstrap sudo figlet graphviz apache2 python-yaml python-pip mr subversion subversion-tools vnstat
+ debootstrap sudo figlet graphviz apache2 python-yaml python-pip mr subversion subversion-tools vnstat webcheck
explain "Packages installed."
#