summaryrefslogtreecommitdiffstats
path: root/job-cfg
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2015-08-03 00:57:32 +0200
committerHolger Levsen <holger@layer-acht.org>2015-08-03 00:57:32 +0200
commitf8c90ee8c02c41e016d5971217ffec2bb4be3250 (patch)
treed67ac81f329be390fc94e40e6ddc16a12d851e59 /job-cfg
parent5ed438cfae052faa160c802b684f71d48c7a1427 (diff)
downloadjenkins.debian.net-f8c90ee8c02c41e016d5971217ffec2bb4be3250.tar.xz
disable irc notifications for d-i_build* jobs due to gcc5 transition
Diffstat (limited to 'job-cfg')
-rwxr-xr-xjob-cfg/d-i.yaml.py4
-rwxr-xr-xjob-cfg/qa.debian.org-tests.yaml.py121
2 files changed, 123 insertions, 2 deletions
diff --git a/job-cfg/d-i.yaml.py b/job-cfg/d-i.yaml.py
index 15b7fa1d..d49e88ee 100755
--- a/job-cfg/d-i.yaml.py
+++ b/job-cfg/d-i.yaml.py
@@ -324,8 +324,8 @@ data.extend(
'logrotate': lr(90),
'publishers': publ(irc=irc)}}
for (n,bdsc,br,trg,irc)
- in [('d-i-build', 'master branch', 'origin/master', 'H/6 * * * *', 'debian-boot'),
- ('d-i-pu-build', 'pu/ branches', 'origin/pu/**' , 'H/10 * * * *', 'debian-boot')]])
+ in [('d-i-build', 'master branch', 'origin/master', 'H/6 * * * *', ''), # irc should be 'debian-boot' but disabled due to gcc5 transition
+ ('d-i-pu-build', 'pu/ branches', 'origin/pu/**' , 'H/10 * * * *', '')]]) # same
data.append(
jobspec_svn(key='job-template',
diff --git a/job-cfg/qa.debian.org-tests.yaml.py b/job-cfg/qa.debian.org-tests.yaml.py
new file mode 100755
index 00000000..880003c1
--- /dev/null
+++ b/job-cfg/qa.debian.org-tests.yaml.py
@@ -0,0 +1,121 @@
+#!/usr/bin/python
+
+packages = """
+ lintian
+ debsums
+ """.split()
+
+shell = { 'lintian': 'timeout 6h debian/rules runtests',
+ 'debsums': 'timeout 5m prove -v' }
+
+distros = { 'lintian': ( 'sid', 'jessie', 'wheezy backports' ),
+ 'debsums': ( 'sid', 'jessie', 'wheezy' ) }
+#FIXME: add stretch too
+recipients = { 'lintian': 'jenkins+debian-qa qa-jenkins-scm@lists.alioth.debian.org lintian-maint@debian.org',
+ 'debsums': 'jenkins+debian-qa qa-jenkins-scm@lists.alioth.debian.org pkg-perl-maintainers@lists.alioth.debian.org'
+ }
+
+git-repo = { 'lintian': 'git://anonscm.debian.org/lintian/lintian.git',
+ 'debsums': 'git://anonscm.debian.org/pkg-perl/packages/debsums.git' }
+
+#
+# nothing to edit below
+#
+
+print("""
+- defaults:
+ name: qa.debian.org-tests
+ project-type: freestyle
+ properties:
+ - sidebar:
+ url: https://jenkins.debian.net/userContent/about.html
+ text: About jenkins.debian.net
+ icon: /userContent/images/debian-swirl-24x24.png
+ - sidebar:
+ url: https://jenkins.debian.net/view/qa.debian.org/
+ text: Jobs for Debian QA related packages
+ icon: /userContent/images/debian-jenkins-24x24.png
+ - sidebar:
+ url: http://www.profitbricks.co.uk
+ text: Sponsored by Profitbricks
+ icon: /userContent/images/profitbricks-24x24.png
+ description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/qa.debian.org-tests.yaml.py">qa.debian.org-tests.yaml.py</a>.'
+ logrotate:
+ daysToKeep: 90
+ numToKeep: 30
+ artifactDaysToKeep: -1
+ artifactNumToKeep: -1
+ scm:
+ - git:
+ url: '{my_repo}'
+ branches:
+ - master
+ builders:
+ - shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} {my_shell}'
+
+""")
+for package in sorted(packages):
+ print("""
+- job-template:
+ defaults: qa.debian.org-tests
+ name: '%(package)s_wheezy'
+ publishers:
+ - email:
+ recipients: '%(recipients)s'
+
+- job-template:
+ defaults: qa.debian.org-tests
+ name: '%(package)s_jessie'
+ publishers:
+ - email:
+ recipients: '%(recipients)s'
+ - trigger:
+ project: '{my_trigger}'
+
+- job-template:
+ defaults: qa.debian.org-tests
+ name: '%(package)s_sid'
+ triggers:
+ - pollscm: '*/6 * * * *'
+ publishers:
+ - email:
+ recipients: '%(recipients)s'
+ - trigger:
+ project: '{my_trigger}'
+""" %
+ dict(package=package,
+ recipients=recipients[package]))
+
+print("""
+- project:
+ name: qa.debian.org-tests
+ jobs:""")
+for package in sorted(packages):
+ print("""
+ my_view: '%(view)s'
+ my_description: '%(description)s'""" %
+ dict(base_distro=base_distro,
+ action=action,
+ shell=shell,
+ prio=prio,
+ trigger=trigger,
+ recipients=get_recipients(target),
+ view=get_view(target, base_distro),
+ second_base=distro_upgrades[base_distro],
+ description=description))
+
+ - '{name}_sid':
+ my_distro: 'sid'
+ my_shell: 'timeout 6h debian/rules runtests'
+ my_description: 'Debian/Lintian testsuite running on sid.'
+ my_trigger: 'qa.debian.org-tests_jessie'
+ - '{name}_jessie':
+ my_distro: 'jessie'
+ my_shell: 'timeout 6h debian/rules runtests'
+ my_description: 'Debian/Lintian testsuite running on jessie.'
+ my_trigger: 'qa.debian.org-tests_wheezy'
+ - '{name}_wheezy':
+ my_distro: 'wheezy backports'
+ my_shell: 'timeout 6h debian/rules runtests'
+ my_description: 'Debian/Lintian testsuite running on wheezy (+backports).'
+