summaryrefslogtreecommitdiffstats
path: root/job-cfg
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-04-06 20:38:00 +0200
committerHolger Levsen <holger@layer-acht.org>2014-04-06 20:38:00 +0200
commit4e94b85e44423bd819af38565595a6c8758d79e0 (patch)
treeff2b8bf91ac1658b10fe244959f7d2ca810ce3a3 /job-cfg
parent54ae35b95cbf60c3222b934bb8f79e0c0dcf6cab (diff)
downloadjenkins.debian.net-4e94b85e44423bd819af38565595a6c8758d79e0.tar.xz
getting tired of fighting jenkins-job-builder even though its the best there is
Diffstat (limited to 'job-cfg')
-rw-r--r--job-cfg/lintian-tests.yaml27
1 files changed, 17 insertions, 10 deletions
diff --git a/job-cfg/lintian-tests.yaml b/job-cfg/lintian-tests.yaml
index 716b7c08..cfddfe39 100644
--- a/job-cfg/lintian-tests.yaml
+++ b/job-cfg/lintian-tests.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.com
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: 'Debian/Lintian test suite.{do_not_edit}'
+ description: '{my_description}{do_not_edit}'
logrotate:
daysToKeep: 365
numToKeep: 365
@@ -26,12 +26,12 @@
branches:
- master
triggers:
- - pollscm: "*/6 * * * *"
+ - pollscm: '*/6 * * * *'
builders:
- - shell: '/srv/jenkins/bin/chroot-run.sh {distro} {my_shell}'
+ - shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} {my_shell}'
publishers:
- email:
- recipients: jenkins+debian-qa holger@layer-acht.org lintian-maint@debian.org
+ recipients: '[my_recipients}'
- job-template:
defaults: lintian-tests
@@ -48,17 +48,24 @@
- project:
name: lintian-tests
do_not_edit: '<br><br>Job configuration source is <a href="http://anonscm.debian.org/gitweb/?p=qa/jenkins.debian.net.git;a=blob;f=job-cfg/lintian-tests.yaml">lintian-tests.yaml</a>.'
+ gitrepo: 'git://anonscm.debian.org/lintian/lintian.git'
jobs:
- '{name}_unstable':
- distro: 'unstable'
- gitrepo: 'git://anonscm.debian.org/lintian/lintian.git'
+ my_distro: 'unstable'
my_shell: 'debian/rules runtests'
+ my_description: 'Debian/Lintian testsuite running on unstable.'
+ my_recipients: 'jenkins+debian-qa holger@layer-acht.org lintian-maint@debian.org'
+
- '{name}_testing':
- distro: 'testing'
- gitrepo: 'git://anonscm.debian.org/lintian/lintian.git'
+ my_distro: 'testing'
my_shell: 'debian/rules runtests'
+ my_description: 'Debian/Lintian testsuite running on testing.'
+ my_recipients: 'jenkins+debian-qa holger@layer-acht.org lintian-maint@debian.org'
+
- '{name}_stable':
- distro: 'stable'
- gitrepo: 'git://anonscm.debian.org/lintian/lintian.git'
+ my_distro: 'stable'
my_shell: 'debian/rules runtests'
+ my_description: 'Debian/Lintian testsuite running on stable.'
+ my_recipients: 'jenkins+debian-qa holger@layer-acht.org lintian-maint@debian.org'
+