summaryrefslogtreecommitdiffstats
path: root/job-cfg/Makefile
diff options
context:
space:
mode:
authorPhilip Hands <phil@hands.com>2015-06-25 08:40:52 +0100
committerHolger Levsen <holger@layer-acht.org>2015-12-11 23:58:35 +0100
commitc9a9a4a44a10ec32cf2e9bf65b8740426511059d (patch)
treedb57b0df46561b5e57de804a315816f318b2ec63 /job-cfg/Makefile
parent2aabe1ebfa81d82f258f2812bb5e5a6f0f6e52d7 (diff)
downloadjenkins.debian.net-c9a9a4a44a10ec32cf2e9bf65b8740426511059d.tar.xz
makefile for test XML
Diffstat (limited to 'job-cfg/Makefile')
-rw-r--r--job-cfg/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/job-cfg/Makefile b/job-cfg/Makefile
new file mode 100644
index 00000000..bf324c95
--- /dev/null
+++ b/job-cfg/Makefile
@@ -0,0 +1,20 @@
+
+
+PYYAMLS := $(basename $(wildcard *.yaml.py))
+
+YAMLS := $(wildcard *.yaml) $(PYYAMLS)
+
+XMLS := $(patsubst %.yaml,%.xml,$(YAMLS))
+
+OUTPUTS := $(PYYAMLS) $(XMLS)
+
+all: $(OUTPUTS)
+
+%.yaml: %.yaml.py
+ ./$< > $@
+
+%.xml: %.yaml
+ jenkins-jobs test $< > $@
+
+clean:
+ rm $(sort $(OUTPUTS))