summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-12-18 15:16:40 +0100
committerHolger Levsen <holger@layer-acht.org>2012-12-18 15:16:40 +0100
commit80051ba36998ef0fdbd111d9cdc26c3b955c93ef (patch)
treeb44ea1fb2e6d8c0e392f73a6447e410c96041b0f /debian
parente7555e0816d50eb923ab21453f047a2a28d04d82 (diff)
downloadjenkins.debian.net-80051ba36998ef0fdbd111d9cdc26c3b955c93ef.tar.xz
further improve debian packaging: build docs
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/docs3
-rw-r--r--debian/jenkins.debian.net-bin.docs3
-rwxr-xr-xdebian/rules16
4 files changed, 16 insertions, 8 deletions
diff --git a/debian/control b/debian/control
index f7484f68..74c5f377 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: extra
Maintainer: Holger Levsen <holger@debian.org>
Build-Depends: debhelper (>= 9.20120419~)
-Standards-Version: 3.9.4
+Standards-Version: 3.9.1
Homepage: http://jenkins.debian.net/userContent/about.html
Vcs-Git: git://git.debian.org/git/users/holger/jenkins.debian.net.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=users/holger/jenkins.debian.net.git
diff --git a/debian/docs b/debian/docs
deleted file mode 100644
index f26bcee2..00000000
--- a/debian/docs
+++ /dev/null
@@ -1,3 +0,0 @@
-README
-TODO
-INSTALL
diff --git a/debian/jenkins.debian.net-bin.docs b/debian/jenkins.debian.net-bin.docs
deleted file mode 100644
index 16636bd9..00000000
--- a/debian/jenkins.debian.net-bin.docs
+++ /dev/null
@@ -1,3 +0,0 @@
-INSTALL
-README
-TODO
diff --git a/debian/rules b/debian/rules
index 571f404a..a2080319 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,5 +3,19 @@
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
+ASCIIDOC_PARAMS = "-a numbered -a data-uri -a iconsdir=/etc/asciidoc/images/icons -a scriptsdir=/etc/asciidoc/javascripts -b html5 -a toc -a toclevels=4 -a icons -a stylesheet=$(shell pwd)/theme/debian-asciidoc.css"
+
%:
- dh $@
+ dh $@
+
+override_dh_auto_build:
+ asciidoc $(ASCIIDOC_PARAMS) -o about.html README
+ asciidoc $(ASCIIDOC_PARAMS) -o todo.html TODO
+ asciidoc $(ASCIIDOC_PARAMS) -o setup.html INSTALL
+ mv *html userContent/
+ dh_auto_build
+
+override_dh_auto_clean:
+ rm -vf userContent/*.html
+ dh_auto_clean
+