summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-04-06 13:38:02 +0200
committerHolger Levsen <holger@layer-acht.org>2014-04-06 13:38:02 +0200
commit0cca304c3f53ec8b513a0519a7961a56d5303af1 (patch)
treede369d5d4f32248aaecdb0dc5a5fc2814f0fcfec /bin
parent8992454e6b60ba24625b821870460b8f19ed594c (diff)
downloadjenkins.debian.net-0cca304c3f53ec8b513a0519a7961a56d5303af1.tar.xz
install build-depends if debian/control exists
Diffstat (limited to 'bin')
-rwxr-xr-xbin/chroot-run.sh5
1 files changed, 5 insertions, 0 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index a0f0dd43..436d57ea 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -85,6 +85,11 @@ run() {
cat > $CHROOT_TARGET/tmp/chroot-testrun <<-EOF
$SCRIPT_HEADER
cd /testrun
+if [ -f debian/control ] ; then
+ # install build-depends
+ apt-get -y install build-essential devscripts
+ mk-build-deps -ir
+fi
$@
EOF
chmod +x $CHROOT_TARGET/tmp/chroot-testrun