summaryrefslogtreecommitdiffstats
path: root/bin/templates
diff options
context:
space:
mode:
authorValerie R Young <spectranaut@riseup.net>2016-06-16 09:45:56 -0400
committerHolger Levsen <holger@layer-acht.org>2016-06-17 23:31:29 +0200
commit0c3fcd537bd06556cda1d290ee926e8365969a04 (patch)
tree2353ef2e34f743eef00cf5448769f182e9ed3bf3 /bin/templates
parenteaae777d4ed6a973316c2a96b27422249ddb446f (diff)
downloadjenkins.debian.net-0c3fcd537bd06556cda1d290ee926e8365969a04.tar.xz
reproducible debian: improve package page navigation
Changes made: - suite and arch specific details moved from the top of side bar to the suite and arch section - "notes" and "test history" (suite and arch agnostic) move to the top of side bar - hover text added to most links, starting with either "Go to:" (if the link takes you away from package page) or "Show:" (if the link opens a file in the iframe) - enabled notifications flag still on top left, by "Test Details" header reproducible debian: address mattia's code review comments Signed-off-by: Holger Levsen <holger@layer-acht.org>
Diffstat (limited to 'bin/templates')
-rw-r--r--bin/templates/package_page.mustache44
-rw-r--r--bin/templates/package_suitearch_details.mustache36
-rw-r--r--bin/templates/package_suitearch_section.mustache30
-rw-r--r--bin/templates/status_icon_link.mustache14
4 files changed, 124 insertions, 0 deletions
diff --git a/bin/templates/package_page.mustache b/bin/templates/package_page.mustache
new file mode 100644
index 00000000..059bffb0
--- /dev/null
+++ b/bin/templates/package_page.mustache
@@ -0,0 +1,44 @@
+<header class="head">
+ <h2 class="package-name">{{package}}</h2>
+ <ul class="menu">
+ <h3>Test Details
+ <a href="debian/index_notify.html" target="_parent">
+ <span class="notification" title="Notifications for this package are enabled. Every reproducibility related status change will be emailed to the maintainers">{{notify_maintainer}}</span>
+ </a>
+ </h3>
+ {{#notes_uri}}
+ <li><a href="{{notes_uri}}" title="Additional commentary on this packages unreproduciblity"target="main">notes</a></li>
+ {{/notes_uri}}
+ <li>
+ <a href="{{history}}" target="main">test history</a>
+ </li>
+ <h3>Suite and Architecture</h3>
+ {{{suitearch_section_html}}}
+ <h3>General Package Details</h3>
+ <li>
+ <a href="https://tracker.debian.org/{{package}}" title="Go to: Debian Package Tracking Site">PTS</a>
+ <a href="https://bugs.debian.org/src:{{package}}" title="Go to: Debian Bug Tracking Site">BTS</a>
+ </li>
+ <li>
+ <a href="hxttps://sources.debian.net/src/{{package}}/{{version}}/" title="Go to: the package source!">sources</a>
+ <ul class="children">
+ <li>
+ <div><a href="https://sources.debian.net/src/{{package}}/{{version}}/debian">debian/</a></div>
+ <div><a href="https://sources.debian.net/src/{{package}}/{{version}}/debian/changelog">debian/changelog</a></div>
+ <div><a href="https://sources.debian.net/src/{{package}}/{{version}}/debian/control">debian/control</a></div>
+ <div><a href="https://sources.debian.net/src/{{package}}/{{version}}/debian/rules">debian/rules</a></div>
+ </li>
+ </ul>
+ </li>
+ </ul>
+ <ul class="children">
+ <li><a href="{{dashboard_url}}">Debian dashboard</a></li>
+ </ul>
+{{{project_links_html}}}
+</header>
+<iframe id="main" name="main" tabindex="1" src="{{default_view}}">
+ <p>
+ Your browser does not support iframes.
+ Use a different one or follow the links above.
+ </p>
+</iframe>
diff --git a/bin/templates/package_suitearch_details.mustache b/bin/templates/package_suitearch_details.mustache
new file mode 100644
index 00000000..685d6631
--- /dev/null
+++ b/bin/templates/package_suitearch_details.mustache
@@ -0,0 +1,36 @@
+<ul class="children">
+ <li>
+ {{{status_html}}}
+ {{#build_date}}
+ <div><span class="build-time">at {{build_date}}</span></div>
+ {{/build_date}}
+ </li>
+ {{#dbd}}
+ <li>
+ <div>
+ <a href="{{dbd_url}}" title="Show: formatted diffoscope results" target="main">differences</a>
+ {{#dbdtxt_url}}
+ <a href="{{dbdtxt_url}}" target="main">(txt)</a>
+ {{/dbdtxt_url}}
+ </div>
+ </li>
+ {{/dbd}}
+ {{#has_buildloginfo}}
+ <li>
+ {{#buildinfo_uri}}
+ <div>
+ <a href="{{buildinfo_uri}}" title="Show: build info" target="main">buildinfo</a>
+ </div>
+ {{/buildinfo_uri}}
+ <div>
+ {{#rbuild_uri}}
+ <a href="{{rbuild_uri}}" title="Show: log of first build (+some other stuff)" target="main">rbuild ({{rbuild_size}})</a>
+ {{/rbuild_uri}}
+ {{#buildlogs}}
+ <a href="{{build2_uri}}" title="Show: log of second build" target="main">build2 ({{build2_size}})</a>
+ <a href="{{diff_uri}}" title="Show: diff between the first and second builds" target="main">diff</a>
+ {{/buildlogs}}
+ </div>
+ </li>
+ {{/has_buildloginfo}}
+</ul>
diff --git a/bin/templates/package_suitearch_section.mustache b/bin/templates/package_suitearch_section.mustache
new file mode 100644
index 00000000..ed29ba8f
--- /dev/null
+++ b/bin/templates/package_suitearch_section.mustache
@@ -0,0 +1,30 @@
+<ul>
+ {{#architectures}}
+ <li>
+ {{arch}}
+ <ul class="children">
+ {{#suites}}
+ <li class="{{li_classes}}">
+ {{^untested}}
+ <a href="/debian/{{arch}}/{{suite}}/index_{{status}}.html">
+ <img src="/static/{{icon}}" alt="{{spokenstatus}}" title="{{spokenstatus}}"/>
+ </a>
+ {{/untested}}
+ {{#untested}}
+ <img src="/static/{{icon}}" alt="{{spokenstatus}}" title="{{spokenstatus}}"/>
+ {{/untested}}
+ {{^current_suitearch}}
+ <a href="{{package_uri}}" target="_parent" title="{{spokenstatus}}: {{version}} on {{build_date}}">
+ {{version}}
+ </a> in <a href="/debian/{{suite}}/{{arch}}/" title="Go to: summary of all tests for {{arch}}/{{suite}}" target="_parent">{{suite}}</a>
+ {{/current_suitearch}}
+ {{#current_suitearch}}
+ {{version}} in <a href="/debian/{{suite}}/{{arch}}/" title="Go to: summary of all tests for {{arch}}/{{suite}}" target="_parent">{{suite}}</a>
+ {{/current_suitearch}}
+ {{{suitearch_details_html}}}
+ </li>
+ {{/suites}}
+ </ul>
+ </li>
+ {{/architectures}}
+</ul>
diff --git a/bin/templates/status_icon_link.mustache b/bin/templates/status_icon_link.mustache
new file mode 100644
index 00000000..2b866f7a
--- /dev/null
+++ b/bin/templates/status_icon_link.mustache
@@ -0,0 +1,14 @@
+{{^untested}}
+{{#icon}}
+<a href="/debian/{{suite}}/{{arch}}/index_{{status}}.html" title="Go to: summary of all {{spokenstatus}} packages" target="_parent">
+ <img src="/static/{{icon}}" alt="{{spokenstatus}}">
+</a>
+{{/icon}}
+<a href="/debian/{{suite}}/{{arch}}/index_{{status}}.html" title="Go to: summary of all {{spokenstatus}} packages" target="_parent">
+ {{spokenstatus}}
+</a>
+{{/untested}}
+
+{{#untested}}
+{{#icon}}<img src="/static/{{icon}}" alt="{{spokenstatus}}">{{/icon}} {{spokenstatus}}
+{{/untested}}