summaryrefslogtreecommitdiffstats
path: root/bin/reproducible_setup_archlinux_schroot.sh
diff options
context:
space:
mode:
authorkpcyrd <git@rxv.cc>2017-11-02 17:35:45 +0100
committerMattia Rizzolo <mattia@debian.org>2017-11-02 17:38:45 +0100
commit3eaf141ab431225bc18701498c15620c5488429a (patch)
tree4623e0e64afb723fe75fe2fd38afaaefacb156b4 /bin/reproducible_setup_archlinux_schroot.sh
parentb6f907f759569b48965faae62274ce7f85f3db05 (diff)
downloadjenkins.debian.net-3eaf141ab431225bc18701498c15620c5488429a.tar.xz
reproducible-archlinux: use pacman-git until the next release
Diffstat (limited to 'bin/reproducible_setup_archlinux_schroot.sh')
-rwxr-xr-xbin/reproducible_setup_archlinux_schroot.sh17
1 files changed, 12 insertions, 5 deletions
diff --git a/bin/reproducible_setup_archlinux_schroot.sh b/bin/reproducible_setup_archlinux_schroot.sh
index bdd31f23..743b348c 100755
--- a/bin/reproducible_setup_archlinux_schroot.sh
+++ b/bin/reproducible_setup_archlinux_schroot.sh
@@ -111,10 +111,17 @@ $ROOTCMD chown -R jenkins:jenkins /var/lib/jenkins
echo ". /etc/profile.d/proxy.sh" | tee -a $SCHROOT_BASE/$TARGET/var/lib/jenkins/.bashrc
$USERCMD bash -l -c 'gpg --check-trustdb' # first run will create ~/.gnupg/gpg.conf
echo "keyserver-options auto-key-retrieve" | tee -a $SCHROOT_BASE/$TARGET/var/lib/jenkins/.gnupg/gpg.conf
-#if [ "$HOSTNAME" = "profitbricks-build3-amd64" ] ; then
-# # YOLO, see YOLO comment above
-# echo "no-autostart" | tee -a $SCHROOT_BASE/$TARGET/var/lib/jenkins/.gnupg/gpg.conf
-#fi
-#$USERCMD bash -l -c 'gpg --recv-keys 0x091AB856069AAA1C'
+
+# NOTE: install pacman-git because there are the reproducible patches we need
+# this is 2017-11-02 on the rws3 in berlin, this can be dropped after the next
+# pacman release.
+# The workaround with sh -c is needed to delay the shell expansion due to chroot
+$USERCMD bash <<-__END__
+ mkdir /pacman-git
+ cd /pacman-git
+ wget -O PKGBUILD https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=pacman-git
+ makepkg
+ __END__
+$ROOTCMD sh -c 'exec pacman -U /pacman-git/pacman-*-x86_64.pkg.tar.xz'
echo "schroot $TARGET set up successfully in $SCHROOT_BASE/$TARGET - exiting now."