summaryrefslogtreecommitdiffstats
path: root/bin/reproducible_setup_archlinux_schroot.sh
diff options
context:
space:
mode:
authorkpcyrd <git@rxv.cc>2017-11-04 15:55:21 +0100
committerHolger Levsen <holger@layer-acht.org>2017-11-04 17:03:40 +0100
commit1c45cf2bc2b29a4e3f108c6e7404281daa53112b (patch)
tree1f1a46c7cf37c7009ad5da57508e8551d514b9e9 /bin/reproducible_setup_archlinux_schroot.sh
parentdf24c1114acb12a52d69d04bea6437ac75c021df (diff)
downloadjenkins.debian.net-1c45cf2bc2b29a4e3f108c6e7404281daa53112b.tar.xz
reproducible-archlinux: ignore expired cert when building in the future
Signed-off-by: Holger Levsen <holger@layer-acht.org>
Diffstat (limited to 'bin/reproducible_setup_archlinux_schroot.sh')
-rwxr-xr-xbin/reproducible_setup_archlinux_schroot.sh12
1 files changed, 10 insertions, 2 deletions
diff --git a/bin/reproducible_setup_archlinux_schroot.sh b/bin/reproducible_setup_archlinux_schroot.sh
index 8a30c822..63ea3d5e 100755
--- a/bin/reproducible_setup_archlinux_schroot.sh
+++ b/bin/reproducible_setup_archlinux_schroot.sh
@@ -105,7 +105,7 @@ if [ "$HOSTNAME" = "profitbricks-build4-amd64" ] ; then
sed -i 's/^SigLevel\s*=.*/SigLevel = Never/' "$SCHROOT_BASE/$TARGET/etc/pacman.conf"
fi
$ROOTCMD bash -l -c 'pacman -Syu --noconfirm'
-$ROOTCMD bash -l -c 'pacman -S --noconfirm base-devel devtools fakechroot asciidoc wget'
+$ROOTCMD bash -l -c 'pacman -S --noconfirm base-devel devtools fakechroot asciidoc'
# configure sudo
echo 'jenkins ALL= NOPASSWD: /usr/sbin/pacman *' | $ROOTCMD tee -a /etc/sudoers
@@ -120,10 +120,18 @@ echo "keyserver-options auto-key-retrieve" | tee -a $SCHROOT_BASE/$TARGET/var/li
# this is 2017-11-02 on the rws3 in berlin, this can be dropped after the next
# pacman release.
# The workaround with sh -c is needed to delay the shell expansion due to chroot
+WGET_OPTS=''
+if [ "$HOSTNAME" = "profitbricks-build4-amd64" ] ; then
+ WGET_OPTS="--no-check-certificate"
+fi
+
+wget $WGET_OPTS -O "$SCHROOT_BASE/$TARGET/tmp/PKGBUILD" "https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=pacman-git"
+
$USERCMD bash <<-__END__
+ set -e
mkdir /pacman-git
cd /pacman-git
- wget -O PKGBUILD https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=pacman-git
+ mv /tmp/PKGBUILD .
makepkg
__END__
$ROOTCMD sh -c 'yes | pacman -U /pacman-git/pacman-*-x86_64.pkg.tar.xz'