summaryrefslogtreecommitdiffstats
path: root/bin/reproducible_coreboot.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2015-06-09 14:47:11 +0200
committerHolger Levsen <holger@layer-acht.org>2015-06-09 14:47:11 +0200
commit344126d92614d04980a8f1b8ce4f4ec1d4956c5c (patch)
tree014c4068eec16108268e375bbc630d06c25b5ccb /bin/reproducible_coreboot.sh
parentdf2364d75ca9ad2bb3c8eedac301675b175ba5a2 (diff)
downloadjenkins.debian.net-344126d92614d04980a8f1b8ce4f4ec1d4956c5c.tar.xz
reproducible coreboot: build crossgcc in parallel
Diffstat (limited to 'bin/reproducible_coreboot.sh')
-rwxr-xr-xbin/reproducible_coreboot.sh5
1 files changed, 3 insertions, 2 deletions
diff --git a/bin/reproducible_coreboot.sh b/bin/reproducible_coreboot.sh
index 0be55dcf..5cd23f8d 100755
--- a/bin/reproducible_coreboot.sh
+++ b/bin/reproducible_coreboot.sh
@@ -14,7 +14,7 @@ common_init "$@"
set -e
# build for different architectures
-ARCHS="i386 mips arm arm64 riscv"
+ARCHS="i386-elf x86_64-elf armv7a-eabi aarch64-elf mipsel-elf riscv-elf"
cleanup_tmpdir() {
cd
@@ -96,7 +96,8 @@ GOT_XTOOLCHAIN=false
set +e
for ARCH in ${ARCHS} ; do
echo "$(date -u) - Building cross compiler for ${ARCH}."
- nice ionice -c 3 make -j $NUM_CPU crossgcc-$ARCH
+ # taken from util/crossgcc/Makefile:
+ nice ionice -c 3 bash util/crossgcc/buildgcc -j $NUM_CPU -p $ARCH
RESULT=$?
if [ $RESULT -eq 0 ] ; then
GOT_XTOOLCHAIN=true