summaryrefslogtreecommitdiffstats
path: root/bin/d-i_manual.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-10-26 00:14:19 +0200
committerHolger Levsen <holger@layer-acht.org>2014-10-26 00:17:37 +0200
commitf82aa51adf4ea5317ef37669319bc9651692e738 (patch)
tree9602abe1fc6447c81855b99fee4c4d909205701c /bin/d-i_manual.sh
parent921eb96288d6240076b8d4b9cb735e4cf76deaf0 (diff)
downloadjenkins.debian.net-f82aa51adf4ea5317ef37669319bc9651692e738.tar.xz
refactor code into new publish_changes_to_userContent()
This new function is used to publish both the Debian Edu manuals as well as the Debian Installer installation-guide to https://jenkins.debian.net/userContent/debian-edu-doc/ and https://jenkins.debian.net/userContent/installation-guide/
Diffstat (limited to 'bin/d-i_manual.sh')
-rwxr-xr-xbin/d-i_manual.sh13
1 files changed, 10 insertions, 3 deletions
diff --git a/bin/d-i_manual.sh b/bin/d-i_manual.sh
index fa014e50..6c9c7e22 100755
--- a/bin/d-i_manual.sh
+++ b/bin/d-i_manual.sh
@@ -21,6 +21,10 @@ init_workspace() {
pdebuild_package() {
#
+ # only used to build the installation-guide package
+ #
+ SOURCE=installation-guide
+ #
# prepare build
#
if [ -f /var/cache/pbuilder/base.tgz ] ; then
@@ -35,9 +39,12 @@ pdebuild_package() {
cd manual
NUM_CPU=$(cat /proc/cpuinfo |grep ^processor|wc -l)
pdebuild --use-pdebuild-internal --debbuildopts "-j$NUM_CPU"
- # cleanup
- SOURCE=$(grep "^Source: " debian/control |cut -d " " -f2)
- sudo dcmd rm /var/cache/pbuilder/result/${SOURCE}_*changes
+ #
+ # publish and cleanup
+ #
+ CHANGES=$(ls /var/cache/pbuilder/result/${SOURCE}_*changes)
+ publish_changes_to_userContent $CHANGES debian-boot "svn-r$SVN_REVISION"
+ sudo dcmd rm $CHANGES
cd ..
}