summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-12-10 17:42:00 +0100
committerHolger Levsen <holger@layer-acht.org>2012-12-10 17:42:00 +0100
commitebc83cdbf0fa2f6e94afea95123d80109100de92 (patch)
tree61eb0a9e18a6af162633de53cf8506350b77d926 /bin/d-i_build.sh
parent02d93508fee08cfcb6703ffa15f993d9ddbe7b5b (diff)
downloadjenkins.debian.net-ebc83cdbf0fa2f6e94afea95123d80109100de92.tar.xz
download upstream tarball with uscan if source/format = 3.0 (quilt)
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh14
1 files changed, 10 insertions, 4 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index a70646a5..3860e978 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -17,8 +17,9 @@ init_workspace() {
#
# clean
#
- rm -fv *.deb *.udeb *.dsc *_*.build *_*.changes *_*.tar.gz
-
+ cd ..
+ rm -fv *.deb *.udeb *.dsc *_*.build *_*.changes *_*.tar.gz *_*.tar.bz2 *_*.tar.xz
+ cd workspace
#
# git clone and pull is done by jenkins job
#
@@ -42,7 +43,6 @@ pdebuild_package() {
grep "Architecture:" debian/control
return
fi
-
#
# prepare build
#
@@ -51,7 +51,13 @@ pdebuild_package() {
else
sudo pbuilder --update
fi
-
+ #
+ # 3.0 quilt is not happy without an upstream tarball
+ #
+ if [ "$(cat debian/source/format)" = "3.0 (quilt)" ] ; then
+ uscan --download-current-version
+ fi
+ #
#
# build
#