summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-04-09 03:20:31 +0200
committerHolger Levsen <holger@layer-acht.org>2014-04-09 03:20:31 +0200
commitdabac51624069f8f491776cede881f9ce2b701b0 (patch)
tree8034765640a788a4e517bd01ecf00f9c05370a09
parenta1cf3bb80e4dfe64b47b1691fb27d5ea243a51d8 (diff)
downloadjenkins.debian.net-dabac51624069f8f491776cede881f9ce2b701b0.tar.xz
use backports for the stable lintian tests
-rwxr-xr-xbin/chroot-run.sh10
-rw-r--r--job-cfg/lintian-tests.yaml3
2 files changed, 10 insertions, 3 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index 03ac4203..32aeec6c 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Copyright 2012-2014 Holger Levsen <holger@layer-acht.org>
# Copyright 2013 Antonio Terceiro <terceiro@debian.org>
@@ -27,6 +27,12 @@ if [ $# -lt 2 ]; then
fi
DISTRO="$1"
+if [ "$DISTRO" == "stable+backports" ] ; then
+ # FIXME: this works but is a bit too hackish for my liking
+ DISTRO = "stable"
+ BACKPORTS = "deb $MIRROR ${DISTRO}-backports main"
+ BACKPORTSSRC = "deb-src $MIRROR ${DISTRO}-backports main"
+fi
shift
if [ ! -d "$CHROOT_BASE" ]; then
@@ -59,6 +65,8 @@ echo -e '#!/bin/sh\nexit 101' > /usr/sbin/policy-rc.d
chmod +x /usr/sbin/policy-rc.d
echo 'Acquire::http::Proxy "$http_proxy";' > /etc/apt/apt.conf.d/80proxy
echo "deb-src $MIRROR $DISTRO main" >> /etc/apt/sources.list
+echo "${BACKPORTS}" >> /etc/apt/sources.list
+echo "${BACKPORTSSRC}" >> /etc/apt/sources.list
apt-get update
EOF
diff --git a/job-cfg/lintian-tests.yaml b/job-cfg/lintian-tests.yaml
index 48999f7e..d6283f1f 100644
--- a/job-cfg/lintian-tests.yaml
+++ b/job-cfg/lintian-tests.yaml
@@ -63,9 +63,8 @@
my_recipients: 'jenkins+debian-qa holger@layer-acht.org lintian-maint@debian.org'
- '{name}_stable':
- my_distro: 'stable'
+ my_distro: 'stable+backports'
my_shell: 'debian/rules runtests'
my_description: 'Debian/Lintian testsuite running on stable.'
my_recipients: 'jenkins+debian-qa holger@layer-acht.org lintian-maint@debian.org'
-