summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Rizzolo <mattia@mapreri.org>2015-01-09 13:26:44 +0100
committerHolger Levsen <holger@layer-acht.org>2015-01-09 13:28:29 +0100
commitc2a458f1a90b7bd4d4c3148175e82b06efc9de29 (patch)
tree9d497f766862951951bf56d1d97c5dcbc5bf4a96
parent166fc78806fcd33db60bc476d6b5dc6d2a4634b0 (diff)
downloadjenkins.debian.net-c2a458f1a90b7bd4d4c3148175e82b06efc9de29.tar.xz
reproducible: update links after apache change. strip the leading /userContent where possible
-rwxr-xr-xbin/reproducible_build.sh6
-rwxr-xr-xbin/reproducible_common.py44
-rwxr-xr-xbin/reproducible_common.sh26
-rwxr-xr-xbin/reproducible_html_dd_list.sh2
-rwxr-xr-xbin/reproducible_html_notes.py4
-rwxr-xr-xbin/reproducible_json.sh2
6 files changed, 42 insertions, 42 deletions
diff --git a/bin/reproducible_build.sh b/bin/reproducible_build.sh
index 9f44fa4f..a9141d36 100755
--- a/bin/reproducible_build.sh
+++ b/bin/reproducible_build.sh
@@ -31,7 +31,7 @@ unschedule_from_db() {
touch -d $PREDATE /var/lib/jenkins/userContent/rb-pkg/${SRCPACKAGE}.html
process_packages $SRCPACKAGE
echo
- echo "Successfully updated the database and updated $REPRODUCIBLE_URL/userContent/rb-pkg/$SRCPACKAGE.html"
+ echo "Successfully updated the database and updated $REPRODUCIBLE_URL/rb-pkg/$SRCPACKAGE.html"
echo
}
@@ -162,12 +162,12 @@ else
rm -f $DBDCHROOT_READLOCK
echo | tee -a ${RBUILDLOG}
if [ $RESULT -eq 124 ] ; then
- echo "$(date) - debbindiff was killed after running into timeout... maybe there is still $REPRODUCIBLE_URL/userContent/dbd/${LOGFILE}" | tee -a ${RBUILDLOG}
+ echo "$(date) - debbindiff was killed after running into timeout... maybe there is still $REPRODUCIBLE_URL/dbd/${LOGFILE}" | tee -a ${RBUILDLOG}
if [ ! -s ./${LOGFILE} ] ; then
echo "$(date) - debbindiff produced no output and was killed after running into timeout..." >> ${LOGFILE}
fi
elif [ $RESULT -eq 1 ] ; then
- DEBBINDIFFOUT="debbindiff found issues, please investigate $REPRODUCIBLE_URL/userContent/dbd/${LOGFILE}"
+ DEBBINDIFFOUT="debbindiff found issues, please investigate $REPRODUCIBLE_URL/dbd/${LOGFILE}"
fi
if [ $RESULT -eq 0 ] && [ ! -f ./${LOGFILE} ] && [ -f b1/${BUILDINFO} ] ; then
cp b1/${BUILDINFO} /var/lib/jenkins/userContent/buildinfo/ > /dev/null 2>&1
diff --git a/bin/reproducible_common.py b/bin/reproducible_common.py
index eaafcedc..72352bda 100755
--- a/bin/reproducible_common.py
+++ b/bin/reproducible_common.py
@@ -20,14 +20,14 @@ DEBUG = False
QUIET = False
BIN_PATH = '/srv/jenkins/bin'
-BASE = '/var/lib/jenkins'
+BASE = '/var/lib/jenkins/userContent'
-REPRODUCIBLE_DB = BASE + '/userContent/reproducible.db'
-REPRODUCIBLE_JSON = BASE + '/userContent/reproducible.json'
+REPRODUCIBLE_DB = BASE + '/reproducible.db'
+REPRODUCIBLE_JSON = BASE + '/reproducible.json'
-NOTES_URI = '/userContent/notes'
-ISSUES_URI = '/userContent/issues'
-RB_PKG_URI = '/userContent/rb-pkg'
+NOTES_URI = '/notes'
+ISSUES_URI = 'issues'
+RB_PKG_URI = '/rb-pkg'
NOTES_PATH = BASE + NOTES_URI
ISSUES_PATH = BASE + ISSUES_URI
RB_PKG_PATH = BASE + RB_PKG_URI
@@ -102,49 +102,49 @@ html_head_page = Template((tab*2).join("""
<ul>
<li>Have a look at:</li>
<li>
- <a href="/userContent/index_reproducible.html" target="_parent">
+ <a href="/index_reproducible.html" target="_parent">
<img src="/userContent/static/weather-clear.png" alt="reproducible icon" />
</a>
</li>
<li>
- <a href="/userContent/index_FTBR_with_buildinfo.html" target="_parent">
+ <a href="/index_FTBR_with_buildinfo.html" target="_parent">
<img src="/userContent/static/weather-showers-scattered.png" alt="FTBR_with_buildinfo icon" />
</a>
</li>
<li>
- <a href="/userContent/index_FTBR.html" target="_parent">
+ <a href="/index_FTBR.html" target="_parent">
<img src="/userContent/static/weather-showers.png" alt="FTBR icon" />
</a>
</li>
<li>
- <a href="/userContent/index_FTBFS.html" target="_parent">
+ <a href="/index_FTBFS.html" target="_parent">
<img src="/userContent/static/weather-storm.png" alt="FTBFS icon" />
</a>
</li>
<li>
- <a href="/userContent/index_404.html" target="_parent">
+ <a href="/index_404.html" target="_parent">
<img src="/userContent/static/weather-severe-alert.png" alt="404 icon" />
</a>
</li>
<li>
- <a href="/userContent/index_not_for_us.html" target="_parent">
+ <a href="/index_not_for_us.html" target="_parent">
<img src="/userContent/static/weather-few-clouds-night.png" alt="not_for_us icon" />
</a>
</li>
<li>
- <a href="/userContent/index_blacklisted.html" target="_parent">
+ <a href="/index_blacklisted.html" target="_parent">
<img src="/userContent/static/error.png" alt="blacklisted icon" />
</a>
</li>
- <li><a href="/userContent/index_issues.html">issues</a></li>
- <li><a href="/userContent/index_notes.html">packages with notes</a></li>
- <li><a href="/userContent/index_scheduled.html">currently scheduled</a></li>
- <li><a href="/userContent/index_last_24h.html">packages tested in the last 24h</a></li>
- <li><a href="/userContent/index_last_48h.html">packages tested in the last 48h</a></li>
- <li><a href="/userContent/index_all_abc.html">all tested packages (sorted alphabetically)</a></li>
- <li><a href="/userContent/index_dd-list.html">maintainers of unreproducible packages</a></li>
- <li><a href="/userContent/index_stats.html">stats</a></li>
- <li><a href="/userContent/index_pkg_sets.html">package sets stats</a></li>
+ <li><a href="/index_issues.html">issues</a></li>
+ <li><a href="/index_notes.html">packages with notes</a></li>
+ <li><a href="/index_scheduled.html">currently scheduled</a></li>
+ <li><a href="/index_last_24h.html">packages tested in the last 24h</a></li>
+ <li><a href="/index_last_48h.html">packages tested in the last 48h</a></li>
+ <li><a href="/index_all_abc.html">all tested packages (sorted alphabetically)</a></li>
+ <li><a href="/index_dd-list.html">maintainers of unreproducible packages</a></li>
+ <li><a href="/index_stats.html">stats</a></li>
+ <li><a href="/index_pkg_sets.html">package sets stats</a></li>
</ul>
</header>""".splitlines(True)))
diff --git a/bin/reproducible_common.sh b/bin/reproducible_common.sh
index 64dd33e8..16516a2b 100755
--- a/bin/reproducible_common.sh
+++ b/bin/reproducible_common.sh
@@ -216,7 +216,7 @@ set_icon() {
write_icon() {
# ICON and STATE_TARGET_NAME are set by set_icon()
- write_page "<a href=\"/userContent/index_${STATE_TARGET_NAME}.html\" target=\"_parent\"><img src=\"/userContent/static/$ICON\" alt=\"${STATE_TARGET_NAME} icon\" /></a>"
+ write_page "<a href=\"/index_${STATE_TARGET_NAME}.html\" target=\"_parent\"><img src=\"/userContent/static/$ICON\" alt=\"${STATE_TARGET_NAME} icon\" /></a>"
}
write_page_header() {
@@ -256,7 +256,7 @@ write_page_header() {
else
SPOKEN_TARGET=${SPOKENTARGET[$TARGET]}
fi
- write_page "<li><a href=\"/userContent/index_${TARGET}.html\">${SPOKEN_TARGET}</a></li>"
+ write_page "<li><a href=\"/index_${TARGET}.html\">${SPOKEN_TARGET}</a></li>"
done
write_page "</ul>"
write_page "</header>"
@@ -282,7 +282,7 @@ publish_page() {
cp $PAGE /var/lib/jenkins/userContent/reproducible.html
fi
rm $PAGE
- echo "Enjoy $REPRODUCIBLE_URL/userContent/$PAGE"
+ echo "Enjoy $REPRODUCIBLE_URL/$PAGE"
}
set_package_star() {
@@ -332,7 +332,7 @@ init_pkg_page() {
echo "<title>$1 - reproducible builds results</title></head>" >> ${PKG_FILE}
echo "<body><table class=\"head\"><tr><td><span style=\"font-size:1.2em;\">$1</span> $2" >> ${PKG_FILE}
set_icon "$3" $5 # this sets $STATE_TARGET_NAME and $ICON
- echo "<a href=\"/userContent/index_${STATE_TARGET_NAME}.html\" target=\"_parent\"><img src=\"/userContent/static/$ICON\" alt=\"${STATE_TARGET_NAME} icon\" /></a>" >> ${PKG_FILE}
+ echo "<a href=\"/index_${STATE_TARGET_NAME}.html\" target=\"_parent\"><img src=\"/userContent/static/$ICON\" alt=\"${STATE_TARGET_NAME} icon\" /></a>" >> ${PKG_FILE}
echo "<span style=\"font-size:0.9em;\">at $4:</span> " >> ${PKG_FILE}
}
@@ -341,7 +341,7 @@ append2pkg_page() {
}
finish_pkg_page() {
- echo "</td><td style=\"text-align:right; font-size:0.9em;\"><a href=\"/userContent/reproducible.html\" target=\"_parent\">reproducible builds</a></td></tr></table>" >> ${PKG_FILE}
+ echo "</td><td style=\"text-align:right; font-size:0.9em;\"><a href=\"/reproducible.html\" target=\"_parent\">reproducible builds</a></td></tr></table>" >> ${PKG_FILE}
echo "<iframe name=\"main\" src=\"$1\" width=\"100%\" height=\"98%\" frameborder=\"0\">" >> ${PKG_FILE}
echo "<p>Your browser does not support iframes. Use a different one or follow the links above.</p>" >> ${PKG_FILE}
echo "</iframe>" >> ${PKG_FILE}
@@ -364,7 +364,7 @@ process_packages() {
MAINLINK=""
NOTES_LINK=""
if [ -f ${NOTES_PATH}/${PKG}_note.html ] ; then
- NOTES_LINK=" <a href=\"/userContent/notes/${PKG}_note.html\" target=\"main\">notes</a> "
+ NOTES_LINK=" <a href=\"/notes/${PKG}_note.html\" target=\"main\">notes</a> "
fi
set_package_star
if [ -f "/var/lib/jenkins/userContent/buildinfo/${PKG}_${EVERSION}_amd64.buildinfo" ] ; then
@@ -374,19 +374,19 @@ process_packages() {
init_pkg_page "$PKG" "$VERSION" "$STATUS" "$BUILD_DATE" "$STAR"
append2pkg_page "${NOTES_LINK}"
if [ -f "/var/lib/jenkins/userContent/buildinfo/${PKG}_${EVERSION}_amd64.buildinfo" ] ; then
- append2pkg_page " <a href=\"/userContent/buildinfo/${PKG}_${EVERSION}_amd64.buildinfo\" target=\"main\">buildinfo</a> "
- MAINLINK="/userContent/buildinfo/${PKG}_${EVERSION}_amd64.buildinfo"
+ append2pkg_page " <a href=\"/buildinfo/${PKG}_${EVERSION}_amd64.buildinfo\" target=\"main\">buildinfo</a> "
+ MAINLINK="/buildinfo/${PKG}_${EVERSION}_amd64.buildinfo"
fi
if [ -f "/var/lib/jenkins/userContent/dbd/${PKG}_${EVERSION}.debbindiff.html" ] ; then
- append2pkg_page " <a href=\"/userContent/dbd/${PKG}_${EVERSION}.debbindiff.html\" target=\"main\">debbindiff</a> "
- MAINLINK="/userContent/dbd/${PKG}_${EVERSION}.debbindiff.html"
+ append2pkg_page " <a href=\"/dbd/${PKG}_${EVERSION}.debbindiff.html\" target=\"main\">debbindiff</a> "
+ MAINLINK="/dbd/${PKG}_${EVERSION}.debbindiff.html"
fi
RBUILD_LOG="rbuild/${PKG}_${EVERSION}.rbuild.log"
if [ -f "/var/lib/jenkins/userContent/${RBUILD_LOG}" ] ; then
SIZE=$(du -sh "/var/lib/jenkins/userContent/${RBUILD_LOG}" |cut -f1)
- append2pkg_page " <a href=\"/userContent/${RBUILD_LOG}\" target=\"main\">rbuild ($SIZE)</a> "
+ append2pkg_page " <a href=\"/${RBUILD_LOG}\" target=\"main\">rbuild ($SIZE)</a> "
if [ "$MAINLINK" = "" ] ; then
- MAINLINK="/userContent/${RBUILD_LOG}"
+ MAINLINK="/${RBUILD_LOG}"
fi
fi
append2pkg_page " <a href=\"https://packages.qa.debian.org/${PKG}\" target=\"main\">PTS</a> "
@@ -395,7 +395,7 @@ process_packages() {
append2pkg_page " <a href=\"https://sources.debian.net/src/${PKG}/${VERSION}/debian/rules\" target=\"main\">debian/rules</a> "
if [ ! -z "${NOTES_LINK}" ] ; then
- MAINLINK="/userContent/notes/${PKG}_note.html"
+ MAINLINK="/notes/${PKG}_note.html"
fi
finish_pkg_page "$MAINLINK"
fi
diff --git a/bin/reproducible_html_dd_list.sh b/bin/reproducible_html_dd_list.sh
index fa38cf26..5e37e519 100755
--- a/bin/reproducible_html_dd_list.sh
+++ b/bin/reproducible_html_dd_list.sh
@@ -28,7 +28,7 @@ while IFS= read -r LINE ; do
if [ "$UPLOADERS" = "$PACKAGE" ] ; then
UPLOADERS=""
fi
- write_page " <a href=\"/userContent/rb-pkg/$PACKAGE.html\">$PACKAGE</a> $UPLOADERS"
+ write_page " <a href=\"/rb-pkg/$PACKAGE.html\">$PACKAGE</a> $UPLOADERS"
else
LINE="$(echo $LINE | sed 's#&#\&amp;#g ; s#<#\&lt;#g ; s#>#\&gt;#g')"
write_page "$LINE"
diff --git a/bin/reproducible_html_notes.py b/bin/reproducible_html_notes.py
index 01c7a516..cf488963 100755
--- a/bin/reproducible_html_notes.py
+++ b/bin/reproducible_html_notes.py
@@ -297,8 +297,8 @@ def index_issues(issues):
html += tab*2 + '</table>\n'
html += tab*2 + '<p>Notes are stored in <a href="https://anonscm.debian.org/cgit/reproducible/notes.git">notes.git</a>.</p>'
title = 'Overview of known issues related to reproducible builds'
- destfile = BASE + '/userContent/index_issues.html'
- desturl = REPRODUCIBLE_URL + '/userContent/index_issues.html'
+ destfile = BASE + '/index_issues.html'
+ desturl = REPRODUCIBLE_URL + '/index_issues.html'
write_html_page(title=title, body=html, destfile=destfile, nofooter=True)
log.info('Issues index now available at ' + desturl)
diff --git a/bin/reproducible_json.sh b/bin/reproducible_json.sh
index 339df19b..aea32913 100755
--- a/bin/reproducible_json.sh
+++ b/bin/reproducible_json.sh
@@ -43,6 +43,6 @@ done < <(echo "$RESULT")
write_json "]"
echo
-echo "$(date) - $REPRODUCIBLE_URL/userContent/reproducible.json has been updated."
+echo "$(date) - $REPRODUCIBLE_URL/reproducible.json has been updated."
mv $JSON /var/lib/jenkins/userContent/reproducible.json
chmod 755 /var/lib/jenkins/userContent/reproducible.json