diff options
author | Holger Levsen <holger@layer-acht.org> | 2015-11-12 19:29:04 +0100 |
---|---|---|
committer | Holger Levsen <holger@layer-acht.org> | 2015-11-12 19:29:04 +0100 |
commit | b859333ade7ffa522259f9e1e8820a5e79c2db09 (patch) | |
tree | 5fae5825387761721664b6c84698a86bc694519a | |
parent | 45cff9d2bf6351283e7cddbb5848eec034731523 (diff) | |
download | jenkins.debian.net-b859333ade7ffa522259f9e1e8820a5e79c2db09.tar.xz |
reproducible: fix syntax to make apt ignore future validation errors
-rw-r--r-- | TODO | 2 | ||||
-rwxr-xr-x | bin/reproducible_setup_pbuilder.sh | 2 | ||||
-rwxr-xr-x | bin/schroot-create.sh | 2 |
3 files changed, 2 insertions, 4 deletions
@@ -174,8 +174,6 @@ This is about Debian, below are more todo entries for other projects… ** check that /srv/workspace/pbuilder/ is cleaned up properly ** right align all numbers in table in the dashboard ** do final s#debbindiff#diffoscope#g and s#dbd#ds#g and rename .debbindiff.html+txt files as well as the dbd directories... -** run pb2-amd64 builder 398 days in the future… (that way we will notice problems soon) -*** Acquire::Check-Valid-Until "false" should help, when setting the time to the future ** pkg sets related: *** fix essential set: currently it only has the ones explicitly marked Essential:yes; they and their dependencies make up the full "essential closure set" (sometimes also called pseudo-essential) *** replace bin/reproducible_installed_on_debian.org with a proper data provider from DSA, eg https://anonscm.debian.org/cgit/mirror/debian.org.git/plain/debian/control diff --git a/bin/reproducible_setup_pbuilder.sh b/bin/reproducible_setup_pbuilder.sh index 4fdee352..753d7fae 100755 --- a/bin/reproducible_setup_pbuilder.sh +++ b/bin/reproducible_setup_pbuilder.sh @@ -68,7 +68,7 @@ echo for i in \$(dpkg -l |grep ^ii |awk -F' ' '{print \$2}'); do apt-cache madison "\$i" | head -1 | grep reproducible.alioth.debian.org || true ; done echo echo "Configuring APT to ignore the Release file expiration" -echo 'Acquire::Check-Valid-Until "false"' > /etc/apt/apt.conf.d/398future +echo 'Acquire::Check-Valid-Until "false";' > /etc/apt/apt.conf.d/398future echo EOF } diff --git a/bin/schroot-create.sh b/bin/schroot-create.sh index 8637fa6e..4f572f2f 100755 --- a/bin/schroot-create.sh +++ b/bin/schroot-create.sh @@ -93,7 +93,7 @@ Mb0BawlXZui0MNUSnZtxHMxrjejdvZdqtskHl9srB1QThH0jasmUqbQPxCnxMbf1 -----END PGP PUBLIC KEY BLOCK-----" | apt-key add - echo echo "Configuring APT to ignore the Release file expiration" -echo 'Acquire::Check-Valid-Until "false"' > /etc/apt/apt.conf.d/398future +echo 'Acquire::Check-Valid-Until "false";' > /etc/apt/apt.conf.d/398future echo EOF } |