summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-11-22 01:27:56 +0100
committerHolger Levsen <holger@layer-acht.org>2012-11-22 01:27:56 +0100
commitabd456f080d75036f8c1c1d139a745f2582dad1e (patch)
tree10585365a2e797cc55700749c527357d96bf83e2
parent65749805534a6eca256f3e1fbcca8d7e58f9dfed (diff)
downloadjenkins.debian.net-abd456f080d75036f8c1c1d139a745f2582dad1e.tar.xz
revert last commit, the plugin cannot handle svn over http...
-rw-r--r--README2
-rw-r--r--job-cfg/d-i.yaml16
2 files changed, 9 insertions, 9 deletions
diff --git a/README b/README
index 210cb4ae..112560fe 100644
--- a/README
+++ b/README
@@ -65,7 +65,7 @@ Remember, this is still pretty much work in progress. If you can think of ways t
* d_i_build_* - there is one job for each git repo referred to in http://anonscm.debian.org/viewvc/d-i/trunk/.mrconfig?view=co
Each job pdebuilds the master branch of its git repo on every git push in a sid environment. (If the architecture(s) specified in debian/control are not amd64,all or any the build exits cleanly.)
** while these jobs are triggered on commits, the SCM is only polled every 6min to see if there are new commits.
-* d_i_manual - builds the full installation-guide package with pdebuild in sid on every commit to http://anonscm.debian.org/svn/svn/d-i/ matching these patterns:
+* d_i_manual - builds the full installation-guide package with pdebuild in sid on every commit to svn://svn.debian.org/svn/d-i/ matching these patterns:
'/trunk/manual/debian/.\*', '/trunk/manual/po/.\*', '/trunk/manual/doc/.\*' and '/trunk/manual/scripts/.\*'
** while this job is triggered on commits, the SCM is only polled every 15min to see if there are new commits.
* d_i_manual_*_html - builds a language (on wheezy) on every commit of svn/trunk/manual/$LANG with "make languages=$LANG architectures=amd64 formats=html". On successful build, d_i_manual_$lang_pdf is triggered.
diff --git a/job-cfg/d-i.yaml b/job-cfg/d-i.yaml
index db6dbc54..053b1e8a 100644
--- a/job-cfg/d-i.yaml
+++ b/job-cfg/d-i.yaml
@@ -41,10 +41,10 @@
url: http://www.profitbricks.com
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>http://anonscm.debian.org/svn/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
+ description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>svn://svn.debian.org/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
scm:
- svn:
- url: http://anonscm.debian.org/svn/svn/d-i/trunk
+ url: svn://svn.debian.org/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/{lang}/.*'
@@ -93,10 +93,10 @@
url: http://www.profitbricks.com
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>http://anonscm.debian.org/svn/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
+ description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>svn://svn.debian.org/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
scm:
- svn:
- url: http://anonscm.debian.org/svn/svn/d-i/trunk
+ url: svn://svn.debian.org/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/po/{lang}/.*'
@@ -148,7 +148,7 @@
description: 'Builds the {languagename} pdf version of the installation-guide for all architectures. Triggered by successful build of <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_html</a>. {do_not_edit}'
scm:
- svn:
- url: http://anonscm.debian.org/svn/svn/d-i/trunk
+ url: svn://svn.debian.org/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/{lang}/.*'
@@ -196,7 +196,7 @@
description: 'Builds the {languagename} pdf version of the installation-guide for all architectures. Triggered by successful build of <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_html</a>. {do_not_edit}'
scm:
- svn:
- url: http://anonscm.debian.org/svn/svn/d-i/trunk
+ url: svn://svn.debian.org/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/{lang}/.*'
@@ -263,10 +263,10 @@
- job-template:
defaults: d-i
name: '{name}_manual'
- description: 'Builds the installation-guide package. Triggered by SVN commits to <code>http://anonscm.debian.org/svn/svn/d-i/</code> matching these patterns: <pre>{include}</pre> {do_not_edit}'
+ description: 'Builds the installation-guide package. Triggered by SVN commits to <code>svn://svn.debian.org/svn/d-i/</code> matching these patterns: <pre>{include}</pre> {do_not_edit}'
scm:
- svn:
- url: http://anonscm.debian.org/svn/svn/d-i/trunk
+ url: svn://svn.debian.org/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '{include}'