summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-04-15 01:27:36 +0200
committerHolger Levsen <holger@layer-acht.org>2014-04-15 01:27:36 +0200
commit7e2eeb1906fb58dc5732f42604628ad945603415 (patch)
treed63737b31c105755118b196b93e50a01bcaab342
parentdd02ba46ef2fe267942cccb4973ca613ec396888 (diff)
downloadjenkins.debian.net-7e2eeb1906fb58dc5732f42604628ad945603415.tar.xz
chroot-run.sh: support backports in a less hackish way
-rwxr-xr-xbin/chroot-run.sh10
-rw-r--r--job-cfg/lintian-tests.yaml4
2 files changed, 7 insertions, 7 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index 7ca5122c..3f3793b1 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -22,18 +22,18 @@ if [ -z "$CHROOT_BASE" ]; then
fi
if [ $# -lt 2 ]; then
- echo "usage: $0 DISTRO CMD [ARG1 ARG2 ...]"
+ echo "usage: $0 DISTRO [backports] CMD [ARG1 ARG2 ...]"
exit 1
fi
DISTRO="$1"
-if [ "$DISTRO" == "wheezy+backports" ] ; then
- # FIXME: this works but is a bit too hackish for my liking, ie it will break when jessie will be stable..
- DISTRO="wheezy"
+shift
+
+if [ "$1" == "backports" ] ; then
BACKPORTS="deb $MIRROR ${DISTRO}-backports main"
BACKPORTSSRC="deb-src $MIRROR ${DISTRO}-backports main"
+ shift
fi
-shift
if [ ! -d "$CHROOT_BASE" ]; then
echo "Directory $CHROOT_BASE does not exist, aborting."
diff --git a/job-cfg/lintian-tests.yaml b/job-cfg/lintian-tests.yaml
index ca3fd33e..8b3dd383 100644
--- a/job-cfg/lintian-tests.yaml
+++ b/job-cfg/lintian-tests.yaml
@@ -67,7 +67,7 @@
my_shell: 'debian/rules runtests'
my_description: 'Debian/Lintian testsuite running on jessie.'
- '{name}_wheezy':
- my_distro: 'wheezy+backports'
+ my_distro: 'wheezy backports'
my_shell: 'debian/rules runtests'
- my_description: 'Debian/Lintian testsuite running on wheezy.'
+ my_description: 'Debian/Lintian testsuite running on wheezy (+backports).'