summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2016-01-21 11:48:05 +0100
committerHolger Levsen <holger@layer-acht.org>2016-01-21 11:48:05 +0100
commit27281b2917fef7a62f22abb738eacff21c76acda (patch)
tree28fc9af4b9c854c350e219110d4b3d86473bfd16
parentee081c6930369a8b94ca293d61a37591d873765a (diff)
downloadjenkins.debian.net-27281b2917fef7a62f22abb738eacff21c76acda.tar.xz
reproducible: link to same pkg set on the other arch
-rw-r--r--TODO1
-rwxr-xr-xbin/reproducible_html_pkg_sets.sh12
2 files changed, 11 insertions, 2 deletions
diff --git a/TODO b/TODO
index a9fb2ff0..99e77066 100644
--- a/TODO
+++ b/TODO
@@ -159,7 +159,6 @@ The plan is to run a jenkins.d.o host, which is maintained by DSA, but we are ma
** rewrite bin/schroot-create.sh from scratch, with little sudo.
** right align all numbers in table in the dashboard
** pkg sets related:
-*** link to that pkg set on another arch
*** add new pkg set: torbrowser-build-depends
*** fix essential set: currently it only has the ones explicitly marked Essential:yes; they and their dependencies make up the full "essential closure set" (sometimes also called pseudo-essential)
*** replace bin/reproducible_installed_on_debian.org with a proper data provider from DSA, eg https://anonscm.debian.org/cgit/mirror/debian.org.git/plain/debian/control
diff --git a/bin/reproducible_html_pkg_sets.sh b/bin/reproducible_html_pkg_sets.sh
index ec79f733..9bf63077 100755
--- a/bin/reproducible_html_pkg_sets.sh
+++ b/bin/reproducible_html_pkg_sets.sh
@@ -142,7 +142,17 @@ create_pkg_sets_pages() {
fi
LABEL="package set '${META_PKGSET[$j]}' in $SUITE/$ARCH"
write_page "<p><a href=\"/userContent/$SUITE/$ARCH/$PNG\"><img src=\"/userContent/$SUITE/$ARCH/$PNG\" class=\"overview\" alt=\"$LABEL\"></a>"
- write_page "<br />The package set '${META_PKGSET[$i]}' in $SUITE/$ARCH consists of: <br />&nbsp;<br />"
+ write_page "<br />The package set '${META_PKGSET[$i]}' in $SUITE/$ARCH consists of:"
+ if [ "$ARCH" = "amd64" ] ; then
+ local LINKED_ARCH=armhf
+ else
+ local LINKED_ARCH=amd64
+ fi
+ # no pkg sets for armhf on testing yet:
+ if [ "$SUITE" != "testing" ] ; then
+ write_page " (this set on <a href=\"/$SUITE/$LINKED_ARCH/pkg_set_${META_PKGSET[$i]}.html\">$LINKED_ARCH</a>)"
+ fi
+ write_page "<br />&nbsp;<br />"
set_icon unreproducible
write_icon
write_page "$COUNT_META_BAD ($PERCENT_META_BAD%) packages failed to build reproducibly:"