summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-12-02 15:35:12 +0100
committerHolger Levsen <holger@layer-acht.org>2012-12-02 15:35:12 +0100
commit1472255921d061b58049bc268fa6f32e526d557f (patch)
tree6d3ea0334fc1674461ca1ecc933452a3f0bb4c9c
parent67491d9ec934a1067355fe4fbeb68a3e6d197258 (diff)
downloadjenkins.debian.net-1472255921d061b58049bc268fa6f32e526d557f.tar.xz
press ctrl-key to avoid screensaver kicking in
-rw-r--r--INSTALL13
-rwxr-xr-xbin/cd_tester.sh6
-rwxr-xr-xupdate_jdn.sh2
3 files changed, 16 insertions, 5 deletions
diff --git a/INSTALL b/INSTALL
index b5024afe..1ca190a9 100644
--- a/INSTALL
+++ b/INSTALL
@@ -60,12 +60,10 @@ cd jenkins.debian.net
./update_jdn.sh
----
-'jenkins-job-builder' and (currently) 'kgb-client' is the only software which is not covered by this script.
+'jenkins-job-builder', 'vncdotool' and (currently) 'kgb-client' are the only software which is not covered by this script.
=== Installing jenkins-job-builder
-This is the only software which needs manual installation and is not covered by 'update_jdn.sh'
-
----
pip install python-jenkins
@@ -93,6 +91,15 @@ The jenkins jobs are configured to send email to 'jenkins+$IRC_CHANNEL' (like 'j
The Jenkins EMail notification plugin is used as its state tracking is best (and the Jenkins IRC plugin is way too powerful).
+=== Installing vncdotool
+
+----
+apt-get install python-twisted python-imaging
+git clone https://github.com/sibson/vncdotool
+cd vncdotool/
+python setup.py
+----
+
=== munin
link://munin-monitoring[Munin] is installed, running with link:http://jenkins.debian.net/munin/[jenkins plugins] not yet published elsewhere.
diff --git a/bin/cd_tester.sh b/bin/cd_tester.sh
index 54ccd2d2..9f148674 100755
--- a/bin/cd_tester.sh
+++ b/bin/cd_tester.sh
@@ -63,7 +63,7 @@ bootstrap() {
case $NAME in
debian-edu-wheezy)
echo "fire up qemu now..."
- sudo qemu-system-x86_64 -cdrom $IMAGE -hda $NAME.qcow -boot d -m 1024 -display vnc=localhost:$DISPLAY --kernel $IMAGE_MNT/install.amd/vmlinuz --append "auto=true priority=critical url=http://10.0.2.2/userContent/$NAME-preseed.cfg video=vesa:ywrap,mtrr vga=788 acpi=off initrd=/install.amd/gtk/initrd.gz -- quiet" --initrd $IMAGE_MNT/install.amd/gtk/initrd.gz &
+ sudo qemu-system-x86_64 -cdrom $IMAGE -hda $NAME.qcow -boot d -m 1024 -display vnc=localhost:$DISPLAY --kernel $IMAGE_MNT/install.amd/vmlinuz --append "auto=true priority=critical url=http://10.0.2.2/userContent/$NAME-preseed.cfg video=vesa:ywrap,mtrr vga=788 initrd=/install.amd/gtk/initrd.gz -- quiet" --initrd $IMAGE_MNT/install.amd/gtk/initrd.gz &
;;
*) echo "unsupported distro."
exit 1
@@ -95,6 +95,10 @@ monitor_installation() {
if [ $(($NR % 15)) -eq 0 ] ; then
date
fi
+ # press ctrl-key to avoid screensaver kicking in
+ if [ $(($NR % 150)) -eq 0 ] ; then
+ vncdo -s localhost:$DISPLAY key ctrl
+ fi
done
set -x
if [ $NR -eq 9000 ] ; then
diff --git a/update_jdn.sh b/update_jdn.sh
index d8c3ee52..dd559eea 100755
--- a/update_jdn.sh
+++ b/update_jdn.sh
@@ -25,7 +25,7 @@ done
#
sudo apt-get install vim screen less etckeeper moreutils curl mtr-tiny dstat devscripts bash-completion shorewall shorewall6 cron-apt apt-listchanges munin calamaris visitors procmail libjson-rpc-perl libfile-touch-perl \
build-essential python-setuptools \
- debootstrap sudo figlet graphviz apache2 python-yaml python-pip mr subversion subversion-tools vnstat webcheck poxml qemu vncsnapshot imagemagick ffmpeg2theora
+ debootstrap sudo figlet graphviz apache2 python-yaml python-pip mr subversion subversion-tools vnstat webcheck poxml qemu vncsnapshot imagemagick ffmpeg2theora python-twisted python-imaging
explain "Packages installed."
#