summaryrefslogtreecommitdiffstats
path: root/web
diff options
context:
space:
mode:
Diffstat (limited to 'web')
-rw-r--r--web/README104
-rw-r--r--web/html/404.php2
-rw-r--r--web/html/account.php2
-rw-r--r--web/html/addvote.php2
-rw-r--r--web/html/comaintainers.php2
-rw-r--r--web/html/css/aurweb.css (renamed from web/html/css/aur.css)3
-rw-r--r--web/html/home.php4
-rw-r--r--web/html/index.php2
-rw-r--r--web/html/login.php2
-rw-r--r--web/html/packages.php2
-rw-r--r--web/html/passreset.php2
-rw-r--r--web/html/pkgbase.php2
-rw-r--r--web/html/pkgdel.php2
-rw-r--r--web/html/pkgmerge.php2
-rw-r--r--web/html/pkgreq.php2
-rw-r--r--web/html/tu.php2
-rw-r--r--web/html/voters.php2
-rw-r--r--web/lib/version.inc.php2
-rw-r--r--web/template/cgit/footer.html2
-rw-r--r--web/template/footer.php4
-rw-r--r--web/template/header.php2
-rw-r--r--web/template/template.phps2
22 files changed, 24 insertions, 127 deletions
diff --git a/web/README b/web/README
deleted file mode 100644
index 96aade5..0000000
--- a/web/README
+++ /dev/null
@@ -1,104 +0,0 @@
-==============
-AUR Web Interface
-==============
-
-Terms and Definitions:
-================
-AUR - Arch User Repository
- Repository made up of a collection of build scripts that are
- created and submitted by the Arch community.
-
-TU - Trusted User
- A user that can add binary packages to the [community]
- repository and administer AUR.
-
-[unsupported]
- The collection of package build files hosted via the AUR website.
-
-File Hierachy
-=========
-
-Directory Layout:
--------------------
-./html - DocumentRoot for AUR, where the PHP scripts live.
-./html/css - CSS for AUR appearance
-./html/css/navbar - CSS for Arch navigation bar appearance
-./html/images - Any AUR images live here.
-./lib - Supporting PHP include files. Access denied to Apache.
-./locale
-./template - Where most of the html markup resides and minimal
- amount of PHP scripting.
-./template/stats
-
-./html Files:
--------------
-account.php -
- PHP script to handle registering for a new account. It prompts
- the visitor for account information: desired username, E-mail,
- password, real name, IRC nick, and default language. The info is
- recorded in the Users table.
-
- A logged-in user can change any of their own account information. If a
- TU or Developer is logged into the system, they can search for and
- edit accounts. A TU can change an account to a TU or User account. A
- Developer can also change an account to the Developer type. TUs and
- Developers are able to suspend accounts. If an account is suspended,
- all packages are orphaned (the MaintainerUID field in the Packages
- table is set to NULL).
-
-addvote.php -
- A form to submit proposals relating to the AUR. Only accessible to TUs
- and Developers. Can be used to vote on a potential new TU, or any
- other proposal that needs a vote. Length of the vote can be specified.
-
-index.php -
- Main page for the AUR. Provides links to all other pages in the AUR.
- Gives a brief synopsis of what the AUR is and where to go for more
- information.
-
-logout.php -
- Logs out a logged-in user. Clears the session id from the Sessions
- table and unsets the cookie.
-
-packages.php -
- Page used to search the package database. Supports searching by name,
- category, maintainer, popularity, etc. Also provides the ability to go
- to a package page which has specific information for that package.
- A specific package page includes the name, description, votes, etc.
- As well as the ability to perform actions on the packages, such as
- flagging or leaving a comment on the package.
-
-passreset.php -
- A page for a user to enter their e-mail and receive a reset e-mail to
- replace the forgotten password.
-
-pkgsubmit.php -
- Page for users to upload a new package. Only allows upload of a
- tarball that has been compressed with gzip. Tarball must contain the
- PKGBUILD, scriptlets, and any other files necessary to build the
- package from source. The user can select a category for the package.
- The page makes appropriate entries into the database for tracking the
- newly added source package and associated information.
-
-rpc.php -
- A frontend for tools to obtain raw information from the AUR. Features
- the ability to search for a package, return information on a package,
- return information on multiple packages, and search for a specific
- package maintainer. Functionality through HTTP GET.
-
-rss.php -
- Generates RDF Site Summary (RSS) feed with the latest packages updated
- in the AUR. Lists most recent 20 packages. Includes package name, link
- to package page, package description, time of update, source listing,
- maintainer name.
-
-tu.php -
- Page only available to TUs and Developers. Shows ongoing votes for
- proposals and past votes for proposals. Current votes can be voted on
- with a "Yes" vote, "No" vote, or an "Abstain" vote. Developers and TUs
- can only vote once. Cannot vote on a proposal about themselves.
-
-voters.php -
- Page only available to TUs and Developers. Shows list of users that
- voted for a specific package. Each username links to the user's
- account information page.
diff --git a/web/html/404.php b/web/html/404.php
index 06ad683..a47ae1e 100644
--- a/web/html/404.php
+++ b/web/html/404.php
@@ -11,4 +11,4 @@ html_header( __("Page Not Found") );
</div>
<?php
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/account.php b/web/html/account.php
index 3dc8ef0..a4c630e 100644
--- a/web/html/account.php
+++ b/web/html/account.php
@@ -136,6 +136,6 @@ if (isset($_COOKIE["AURSID"])) {
echo "</div>";
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
?>
diff --git a/web/html/addvote.php b/web/html/addvote.php
index 0b6b9c6..0372518 100644
--- a/web/html/addvote.php
+++ b/web/html/addvote.php
@@ -113,5 +113,5 @@ if (has_credential(CRED_TU_ADD_VOTE)) {
print __("You are not allowed to access this area.");
}
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/comaintainers.php b/web/html/comaintainers.php
index 591fcad..23d8d19 100644
--- a/web/html/comaintainers.php
+++ b/web/html/comaintainers.php
@@ -16,6 +16,6 @@ if (!isset($base_id) || !has_credential(CRED_PKGBASE_EDIT_COMAINTAINERS, array(p
html_header(__("Manage Co-maintainers"));
$users = pkgbase_get_comaintainers($base_id);
include('comaintainers_form.php');
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/css/aur.css b/web/html/css/aurweb.css
index dfa6717..79acce4 100644
--- a/web/html/css/aur.css
+++ b/web/html/css/aurweb.css
@@ -1,4 +1,5 @@
-/* AUR-specific customizations to "archweb.css". */
+/* aurweb-specific customizations to archweb.css */
+
#archnavbar.anb-aur ul li#anb-aur a {
color: white !important;
}
diff --git a/web/html/home.php b/web/html/home.php
index 556e21b..031ad2b 100644
--- a/web/html/home.php
+++ b/web/html/home.php
@@ -45,7 +45,7 @@ html_header( __("Home") );
<p>
<?php
echo __(
- 'General discussion regarding the Arch User Repository (AUR) and Trusted User structure takes place on %saur-general%s. Package orphan requests, merge requests, and deletion requests should be filed in the %sPackage Actions%s box. For discussion relating to the development of the AUR, use the %saur-dev%s mailing list.',
+ 'General discussion regarding the Arch User Repository (AUR) and Trusted User structure takes place on %saur-general%s. Package orphan requests, merge requests, and deletion requests should be filed in the %sPackage Actions%s box. For discussion relating to the development of the AUR web interface, use the %saur-dev%s mailing list.',
'<a href="https://mailman.archlinux.org/mailman/listinfo/aur-general">',
'</a>',
'<var>',
@@ -129,4 +129,4 @@ $(document).ready(function() {
});
</script>
<?php
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/index.php b/web/html/index.php
index cfd6598..fad1d2f 100644
--- a/web/html/index.php
+++ b/web/html/index.php
@@ -143,7 +143,7 @@ if (!empty($tokens[1]) && '/' . $tokens[1] == get_pkg_route()) {
} else {
switch ($path) {
case "/css/archweb.css":
- case "/css/aur.css":
+ case "/css/aurweb.css":
case "/css/cgit.css":
case "/css/archnavbar/archnavbar.css":
header("Content-Type: text/css");
diff --git a/web/html/login.php b/web/html/login.php
index 9818d04..94da559 100644
--- a/web/html/login.php
+++ b/web/html/login.php
@@ -53,4 +53,4 @@ html_header('AUR ' . __("Login"));
<?php endif; ?>
</div>
<?php
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/packages.php b/web/html/packages.php
index 645806e..76f7563 100644
--- a/web/html/packages.php
+++ b/web/html/packages.php
@@ -99,5 +99,5 @@ if (isset($pkgid)) {
}
}
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/passreset.php b/web/html/passreset.php
index fecefe4..bc2eefc 100644
--- a/web/html/passreset.php
+++ b/web/html/passreset.php
@@ -109,4 +109,4 @@ html_header(__("Password Reset"));
<?php
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/pkgbase.php b/web/html/pkgbase.php
index 201749e..ef9b2c4 100644
--- a/web/html/pkgbase.php
+++ b/web/html/pkgbase.php
@@ -155,5 +155,5 @@ if (isset($_COOKIE["AURSID"])) {
pkgbase_display_details($base_id, $details, null);
}
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/pkgdel.php b/web/html/pkgdel.php
index 41900e4..45a3ad4 100644
--- a/web/html/pkgdel.php
+++ b/web/html/pkgdel.php
@@ -45,4 +45,4 @@ if (has_credential(CRED_PKGBASE_DELETE)): ?>
print __("Only Trusted Users and Developers can delete packages.");
endif;
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/pkgmerge.php b/web/html/pkgmerge.php
index df97a2a..5fbdbd8 100644
--- a/web/html/pkgmerge.php
+++ b/web/html/pkgmerge.php
@@ -66,4 +66,4 @@ if (has_credential(CRED_PKGBASE_DELETE)): ?>
print __("Only Trusted Users and Developers can merge packages.");
endif;
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/pkgreq.php b/web/html/pkgreq.php
index ccb0acd..1e671d0 100644
--- a/web/html/pkgreq.php
+++ b/web/html/pkgreq.php
@@ -80,5 +80,5 @@ if (isset($base_id)) {
include('pkgreq_results.php');
}
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/tu.php b/web/html/tu.php
index 158632a..cc77d62 100644
--- a/web/html/tu.php
+++ b/web/html/tu.php
@@ -121,5 +121,5 @@ else {
header('Location: /');
}
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/html/voters.php b/web/html/voters.php
index a40a9a1..8833be1 100644
--- a/web/html/voters.php
+++ b/web/html/voters.php
@@ -31,4 +31,4 @@ if (has_credential(CRED_PKGBASE_LIST_VOTERS)):
<?php
endif;
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);
diff --git a/web/lib/version.inc.php b/web/lib/version.inc.php
index 55caf6c..c4af783 100644
--- a/web/lib/version.inc.php
+++ b/web/lib/version.inc.php
@@ -1,3 +1,3 @@
<?php
-define("AUR_VERSION", "v3.5.1");
+define("AURWEB_VERSION", "v3.5.1");
diff --git a/web/template/cgit/footer.html b/web/template/cgit/footer.html
index f90aeb7..80481d9 100644
--- a/web/template/cgit/footer.html
+++ b/web/template/cgit/footer.html
@@ -1,6 +1,6 @@
<div id="footer">
<p>
- Copyright &copy; 2004-2014 AUR Development Team &ndash;
+ Copyright &copy; 2004-2014 aurweb Development Team &ndash;
<strong>Unsupported packages are user produced content. Any use of the provided files is at your own risk.</strong>
</p>
</div>
diff --git a/web/template/footer.php b/web/template/footer.php
index 806d3be..1b451b3 100644
--- a/web/template/footer.php
+++ b/web/template/footer.php
@@ -3,9 +3,9 @@
<div id="footer">
<?php if ($ver): ?>
- <p>AUR <?= htmlspecialchars($ver) ?></p>
+ <p>aurweb <?= htmlspecialchars($ver) ?></p>
<?php endif; ?>
- <p>Copyright &copy; 2004-<?= date("Y") ?> AUR Development Team.</p>
+ <p>Copyright &copy; 2004-<?= date("Y") ?> aurweb Development Team.</p>
<p><?= __('Unsupported packages are user produced content. Any use of the provided files is at your own risk.') ?></p>
</div>
</div>
diff --git a/web/template/header.php b/web/template/header.php
index 8a1494c..3567536 100644
--- a/web/template/header.php
+++ b/web/template/header.php
@@ -6,7 +6,7 @@
<head>
<title>AUR (<?= htmlspecialchars($LANG); ?>)<?php if ($title != "") { print " - " . htmlspecialchars($title); } ?></title>
<link rel='stylesheet' type='text/css' href='/css/archweb.css' />
- <link rel='stylesheet' type='text/css' href='/css/aur.css' />
+ <link rel='stylesheet' type='text/css' href='/css/aurweb.css' />
<link rel='shortcut icon' href='/images/favicon.ico' />
<link rel='alternate' type='application/rss+xml' title='Newest Packages RSS' href='<?= get_uri('/rss/'); ?>' />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
diff --git a/web/template/template.phps b/web/template/template.phps
index 841277b..4f8117c 100644
--- a/web/template/template.phps
+++ b/web/template/template.phps
@@ -16,5 +16,5 @@ html_header(); # print out the HTML header
print __("Hi, this is worth reading!")."<br />\n";
-html_footer(AUR_VERSION);
+html_footer(AURWEB_VERSION);