summaryrefslogtreecommitdiffstats
path: root/web
diff options
context:
space:
mode:
authorLoui Chang <louipc.ist@gmail.com>2009-01-24 01:22:19 -0500
committerLoui Chang <louipc.ist@gmail.com>2009-01-24 01:22:19 -0500
commitb31b4ec03edd60820b8e4a8d596de9bc2e14d21b (patch)
tree58b62c2704e03569c9915aa3d16639025f203779 /web
parent6bac561bf8cdbdb979417326173ace7a05ea391b (diff)
downloadaurweb-b31b4ec03edd60820b8e4a8d596de9bc2e14d21b.tar.xz
Add package details template (pkg_details.php)
Signed-off-by: Loui Chang <louipc.ist@gmail.com>
Diffstat (limited to 'web')
-rw-r--r--web/html/css/arch.css3
-rw-r--r--web/html/css/containers.css2
-rw-r--r--web/lib/pkgfuncs.inc182
-rw-r--r--web/template/pkg_details.php174
4 files changed, 178 insertions, 183 deletions
diff --git a/web/html/css/arch.css b/web/html/css/arch.css
index 42a6627..ffe713e 100644
--- a/web/html/css/arch.css
+++ b/web/html/css/arch.css
@@ -431,9 +431,6 @@ textarea.vLargeTextField {
.frontpgboxbody > table {
width: 100%;
}
-.boxSoftTitle {
- text-align: right;
-}
.pgboxtitle {
border: 2px solid #ddd;
border-top: 1px solid #fff;
diff --git a/web/html/css/containers.css b/web/html/css/containers.css
index c0fb877..c7a9973 100644
--- a/web/html/css/containers.css
+++ b/web/html/css/containers.css
@@ -95,7 +95,7 @@ td.div {
background-color: #eee;
width: 3px;
}
-td.boxSoftTitle {
+.boxSoftTitle {
border-bottom: 1px solid #fff;
border-top: 1px solid #fff;
background-color: #f1f2f4;
diff --git a/web/lib/pkgfuncs.inc b/web/lib/pkgfuncs.inc
index e328c30..b6f32e6 100644
--- a/web/lib/pkgfuncs.inc
+++ b/web/lib/pkgfuncs.inc
@@ -287,187 +287,11 @@ function package_details($id=0, $SID="") {
if (empty($row)) {
print __("Package details could not be found.")."<br />\n";
- } else {
-
- # print out package details
- #
- echo "<div class=\"pgbox\">\n";
- echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Package Details")."</span></div>\n";
- echo " <div class=\"pgboxbody\">\n";
- echo " <table>\n";
- echo " <tr><td class='boxSoft' colspan='2'><span class='f2'>";
- echo $row["Name"] . " " . $row["Version"]."</span></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><span class='f3'>";
- echo "<a href='".$row["URL"]."'>".$row["URL"]."</a></span></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><span class='f3'>".$row["Description"];
- echo "</a></span></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><img src='/images/pad.gif' height='30'></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><span class='f3'>";
- if ($row["Location"] == "unsupported" and (
- $uid == $row["MaintainerUID"] or
- ($atype == "Developer" or
- $atype == "Trusted User"))) {
- $edit_cat = "<a href='pkgedit.php?change_Category=1&ID=";
- $edit_cat .= intval($_REQUEST["ID"])."'>".$row["Category"]."</a>";
- $edit_cat .= " &nbsp;<span class='fix'>(";
- $edit_cat .= __("change category").")</span>";
- } else {
- $edit_cat = $row["Category"];
- }
- echo $row["Location"]." :: ".$edit_cat."</span></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><span class='f3'>".__("Maintainer").": ";
- if ($row["MaintainerUID"]) {
- $maintainer = username_from_id($row["MaintainerUID"]);
- if ($SID) {
- echo "<a href='account.php?Action=AccountInfo&ID=";
- echo $row["MaintainerUID"] . "'>";
- echo $maintainer . "</a></span></td>";
- } else {
- echo $maintainer . "</span></td>";
- }
- } else {
- $maintainer = "None";
- echo $maintainer . "</span></td>";
- }
- echo " </tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><span class='f3'>".__("Votes").": ";
- echo $row["NumVotes"] . "</span></td></tr>\n";
-
- # In case of wanting to put a custom message
- $msg = __("unknown");
- $license = $row["License"] == "" ? $msg : $row["License"];
-
- echo " <tr><td class='boxSoft' colspan='2'><br><span class='f3'>".__("License").": ".$license;
- echo "</a></span></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><img src='/images/pad.gif' height='15'></td></tr>\n";
-
- # Print the timestamps for last updates
- $updated_time = ($row["ModifiedTS"] == 0) ? "(unknown)" : gmdate("r", intval($row["ModifiedTS"]));
- $submitted_time = ($row["SubmittedTS"] == 0) ? "(unknown)" : gmdate("r", intval($row["SubmittedTS"]));
- echo " <tr><td class='boxSoft' colspan='2'><span class='f3'>";
- echo __("Last Updated").": ".$updated_time."<br>";
- echo __("First Submitted").": ".$submitted_time."</span></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><img src='/images/pad.gif' height='15'></td></tr>\n";
- echo " <tr><td class='boxSoft' colspan='2'><span class='f3'>";
- if ($row["LocationID"] == 2) {
- $urlpath = URL_DIR.$row["Name"]."/".$row["Name"];
- print "<a href='$urlpath.tar.gz'>".__("Tarball")."</a> :: <a href='$urlpath'>".__("Files")."</a> :: <a href='$urlpath/PKGBUILD'>PKGBUILD</a></span></td>";
- } elseif ($row["LocationID"] == 3) {
- echo "<a href='http://repos.archlinux.org/viewvc.cgi/community/" . $row["Category"] . "/" . $row["Name"] . "/?root=community&pathrev=CURRENT'>CVS</td>";
- }
- echo "</tr>\n";
- if ($row["OutOfDate"] == 1) {
- echo "\n<tr><td colspan='2'>";
- echo "<span class='f6'>".__("This package has been flagged out of date.")."</span></td></tr>";
- }
- echo " <tr><td class='boxSoft' colspan='2'><img src='/images/pad.gif' height='30'></td></tr>\n";
-
- $deps = package_dependencies($row["ID"]); # $deps[0] = array('id','name', 'dummy');
- if (count($deps) > 0) {
-
- echo " <tr>\n";
- echo " <td valign='top' style='padding-right: 10'>\n";
- echo " <table class='boxSoft' style='width: 200px'>\n";
- echo " <tr><td class='boxSoftTitle'><span class='f3'>";
- echo __("Dependencies")."</span></td></tr>\n";
- echo " <tr><td class='boxSoft'>";
-
- while (list($k, $darr) = each($deps)) {
- $url = "<a href='packages.php?ID=".$darr[0];
- while(list($k, $var) = each($pkgsearch_vars)) {
- if (($var == "do_Orphans") && $_REQUEST[$var]) {
- $url .= "&".$var."=1";
- } else {
- $url .= "&".$var."=".rawurlencode(stripslashes($_REQUEST[$var]));
- }
- }
- reset($pkgsearch_vars);
-
- // $darr[3] is the DepCondition
-
- if ($darr[2] == 0) echo $url."'>".$darr[1].$darr[3]."</a><br />\n";
- else echo "<a href='http://archlinux.org/packages/search/?q=".$darr[1]."'>".$darr[1].$darr[3]."</a><br />\n";
- }
-
- echo "</td></tr>\n";
- echo "</table></td>";
-
- }
-
- $deps = package_required($row["ID"]);
- if (count($deps) > 0) {
-
- echo " <td valign='top'>";
- echo "<table class='boxSoft' style='width: 200px'>";
- echo "<tr><td class='boxSoftTitle'><span class='f3'>";
- echo __("Required by")."</span></td></tr>\n";
- echo "<tr><td class='boxSoft'>";
-
- while (list($k, $darr) = each($deps)) {
- $url = "<a href='packages.php?ID=".$darr[0];
- while(list($k, $var) = each($pkgsearch_vars)) {
- if (($var == "do_Orphans") && $_REQUEST[$var]) {
- $url .= "&".$var."=1";
- } else {
- $url .= "&".$var."=".rawurlencode(stripslashes($_REQUEST[$var]));
- }
- }
- reset($pkgsearch_vars);
-
- // $darr[3] is the DepCondition
-
- if ($darr[2] == 0) print $url."'>".$darr[1].$darr[3]."</a><br />\n";
- else print "<a href='http://archlinux.org/packages/search/?q=".$darr[1]."'>".$darr[1].$darr[3]."</a><br />\n";
- }
-
- echo "</td></tr>\n";
- echo " </table>\n";
- echo " </td>\n";
-
- }
-
- $sources = package_sources($row["ID"]); # $sources[0] = 'src';
- if (count($sources) > 0) {
-
- echo " <td valign='top'>\n";
- echo " <table class='boxSoft' style='width: 200px'>\n";
- echo " <tr><td class='boxSoftTitle'><span class='f3'>";
- echo __("Sources")."</span></td></tr>\n";
- echo " <tr><td class='boxSoft'>";
-
- while (list($k, $src) = each($sources)) {
- $parsed_url = parse_url($src);
- if ($parsed_url['scheme'])
- {
- //It is an external source
- echo "<a href='".$src."'>".$src."</a><br />\n";
- }
- else
- {
- //It is presumably an internal source
- if ($row["LocationID"] == 2) {
- echo "<a href='".dirname($row['URLPath'])."/".$row['Name'];
- echo "/".$src."'>".$src."</a><br />\n";
- } elseif ($row["LocationID"] == 3) {
- echo "<a href='http://repos.archlinux.org/viewvc.cgi/community/" . $row["Category"] . "/" . $row["Name"] . "/?root=community&pathrev=CURRENT'>";
- echo $src."</a><br />\n";
- }
- }
- }
-
- echo "</td></tr>\n";
- echo " </table>\n";
- echo " </td>\n";
-
- }
-
- echo " </tr>\n";
- echo " </table>\n";
- echo " </div>\n";
- echo "</div>\n\n";
+ }
+ else {
+ include('pkg_details.php');
# Actions Bar
- #
if ($SID) {
include('actions_form.php');
}
diff --git a/web/template/pkg_details.php b/web/template/pkg_details.php
new file mode 100644
index 0000000..ffe735c
--- /dev/null
+++ b/web/template/pkg_details.php
@@ -0,0 +1,174 @@
+<?php
+if ($row["Location"] == "unsupported" and ($uid == $row["MaintainerUID"] or
+ ($atype == "Developer" or $atype == "Trusted User"))) {
+
+ $edit_cat = "<a href='pkgedit.php?change_Category=1&amp;ID=";
+ $edit_cat .= intval($_REQUEST["ID"])."'>".$row["Category"]."</a>";
+ $edit_cat .= " &nbsp;<span class='fix'>(";
+ $edit_cat .= __("change category").")</span>";
+}
+else {
+ $edit_cat = $row['Category'];
+}
+
+if ($row["MaintainerUID"]) {
+ $maintainer = username_from_id($row["MaintainerUID"]);
+ if ($SID) {
+ $maintainer = '<a href="account.php?Action=AccountInfo&amp;ID=' . $row['MaintainerUID'] . '">' . $maintainer . '</a>';
+ }
+
+} else {
+ $maintainer = "None";
+}
+
+# In case of wanting to put a custom message
+$msg = __('unknown');
+$license = empty($row['License']) ? $msg : $row['License'];
+
+# Print the timestamps for last updates
+$updated_time = ($row["ModifiedTS"] == 0) ? "(unknown)" : gmdate("r", intval($row["ModifiedTS"]));
+$submitted_time = ($row["SubmittedTS"] == 0) ? "(unknown)" : gmdate("r", intval($row["SubmittedTS"]));
+
+?>
+<div class="pgbox">
+ <div class="pgboxtitle"><span class="f3"><?php echo __("Package Details") ?></span></div>
+ <div class="pgboxbody">
+
+ <p>
+ <span class='f2'><?php echo $row['Name'] . ' ' . $row['Version'] ?></span><br />
+ <span class='f3'><a href="<?php echo $row['URL'] . '">' . $row['URL'] ?></a></span><br />
+ <span class='f3'><?php echo $row["Description"]; ?></span>
+ </p>
+
+ <p>
+ <span class='f3'><?php echo $row['Location'] . ' :: ' . $edit_cat ?></span><br />
+ <span class='f3'><?php echo __('Maintainer') .': ' . $maintainer ?></span><br />
+ <span class='f3'><?php echo __('Votes') . ': ' . $row['NumVotes'] ?></span>
+ </p>
+
+ <p><span class='f3'><?php echo __('License') . ': ' . $license ?></span></p>
+
+ <p>
+ <span class='f3'>
+ <?php echo __('Last Updated') . ': ' . $updated_time ?><br />
+ <?php echo __('First Submitted') . ': '. $submitted_time ?>
+ </span>
+ </p>
+
+ <p><span class='f3'>
+<?php
+ if ($row['LocationID'] == 2) {
+ $urlpath = URL_DIR . $row['Name'] . '/' . $row['Name'];
+ print "<a href='$urlpath.tar.gz'>".__("Tarball")."</a> :: <a href='$urlpath'>".__("Files")."</a> :: <a href='$urlpath/PKGBUILD'>PKGBUILD</a></span>";
+ }
+ elseif ($row['LocationID'] == 3) {
+ echo "<a href='http://repos.archlinux.org/viewvc.cgi/community/" . $row["Category"] . "/" . $row["Name"] . "/?root=community&pathrev=CURRENT'>CVS</a>";
+ }
+
+ if ($row["OutOfDate"] == 1) {
+ echo "<br /><span class='f6'>".__("This package has been flagged out of date.")."</span>";
+ }
+?>
+ </p>
+<?php
+
+ # $deps[0] = array('id','name', 'dummy');
+ $deps = package_dependencies($row["ID"]);
+ $requiredby = package_required($row["ID"]);
+
+ if (count($deps) > 0 || count($requiredby) > 0) {
+ echo '<p>';
+ }
+
+ if (count($deps) > 0) {
+
+ echo "<span class='boxSoftTitle'><span class='f3'>". __("Dependencies")."</span></span>";
+
+ while (list($k, $darr) = each($deps)) {
+ $url = " <a href='packages.php?ID=".$darr[0];
+ while(list($k, $var) = each($pkgsearch_vars)) {
+ if (($var == "do_Orphans") && $_REQUEST[$var]) {
+ $url .= "&".$var."=1";
+ } else {
+ $url .= "&".$var."=".rawurlencode(stripslashes($_REQUEST[$var]));
+ }
+ }
+ reset($pkgsearch_vars);
+ # $darr[3] is the DepCondition
+ if ($darr[2] == 0) echo $url."'>".$darr[1].$darr[3]."</a>";
+ else echo " <a href='http://archlinux.org/packages/search/?q=".$darr[1]."'>".$darr[1].$darr[3]."</a>";
+ }
+
+ if (count($requiredby) > 0) {
+ echo '<br />';
+ }
+ }
+
+ if (count($requiredby) > 0) {
+
+ echo "<span class='boxSoftTitle'><span class='f3'>". __("Required by")."</span></span>";
+
+ while (list($k, $darr) = each($requiredby)) {
+ $url = " <a href='packages.php?ID=".$darr[0];
+ while(list($k, $var) = each($pkgsearch_vars)) {
+ if (($var == "do_Orphans") && $_REQUEST[$var]) {
+ $url .= "&amp;" . $var . "=1";
+ } else {
+ $url .= "&amp;".$var."=".rawurlencode(stripslashes($_REQUEST[$var]));
+ }
+ }
+ reset($pkgsearch_vars);
+
+ # $darr[3] is the DepCondition
+ if ($darr[2] == 0) {
+ echo $url . "'>" . $darr[1] . $darr[3] . "</a>";
+ }
+ else {
+ print "<a href='http://archlinux.org/packages/search/?q=".$darr[1]."'>".$darr[1].$darr[3]."</a>";
+ }
+ }
+
+ }
+
+ if (count($deps) > 0 || count($requiredby) > 0) {
+ echo '</p>';
+ }
+
+
+ # $sources[0] = 'src';
+ $sources = package_sources($row["ID"]);
+
+ if (count($sources) > 0) {
+
+?>
+ <div class='boxSoftTitle'><span class='f3'><?php echo __('Sources') ?></span></div>
+ <div>
+<?php
+ while (list($k, $src) = each($sources)) {
+ $parsed_url = parse_url($src);
+ if ($parsed_url['scheme'])
+ {
+ # It is an external source
+ echo "<a href='".$src."'>".$src."</a><br />\n";
+ }
+ else
+ {
+ # It is presumably an internal source
+ if ($row["LocationID"] == 2) {
+ echo "<a href='".dirname($row['URLPath'])."/".$row['Name'];
+ echo "/".$src."'>".$src."</a><br />\n";
+ } elseif ($row["LocationID"] == 3) {
+ echo "<a href='http://repos.archlinux.org/viewvc.cgi/community/" . $row["Category"] . "/" . $row["Name"] . "/?root=community&pathrev=CURRENT'>";
+ echo $src."</a><br />\n";
+ }
+ }
+ }
+?>
+ </div>
+<?php
+ }
+
+?>
+
+ </div>
+</div>