summaryrefslogtreecommitdiffstats
path: root/web
diff options
context:
space:
mode:
authorpjmattal <pjmattal>2005-02-23 04:34:19 +0000
committerpjmattal <pjmattal>2005-02-23 04:34:19 +0000
commitaa8135655aa3aba42673ed3aebfbdb08be9d7485 (patch)
tree5e197eeb35d6d0c9248bcadc77bcdeae2f610284 /web
parent03ec762532ac65e0d624fc84a1a1337b5c260b73 (diff)
downloadaurweb-aa8135655aa3aba42673ed3aebfbdb08be9d7485.tar.xz
some fixes in beta manifest
Diffstat (limited to 'web')
-rw-r--r--web/html/beta.html42
1 files changed, 33 insertions, 9 deletions
diff --git a/web/html/beta.html b/web/html/beta.html
index 2e0246d..29bf80a 100644
--- a/web/html/beta.html
+++ b/web/html/beta.html
@@ -136,30 +136,54 @@ step is necessary so we can make sure that the right people are getting
the right access. We will migrate this information to the production
system, so you won't have to do it again.<br>
</li>
- <li>Check out the CVS tree for the AUR repository, located at:<br>
- <code>:pserver:&lt;userid&gt;@cvs.archlinux.org/home/cvs-aur-test</code><br>
+ <li>Check out the CVS tree for the AUR repository. To do this,
+execute the following commands:<br>
+ <br>
+ <code>export
+CVSROOT=":pserver:&lt;userid&gt;@cvs.archlinux.org:/home/cvs-aur-test"<br>
+cvs login<br>
+cvs co aur-test</code><br>
+ <br>
If you're
-a TU or developer, you should already have an account in this new
-repository.</li>
+a TU, you should already have an account in this new
+repository. If you are a developer, email Jason (jason at archlinux dot
+org) and he'll set up access for you.<br>
+ </li>
<li>Build binary packages for things you wish to place in the AUR,
and add the PKGBUILD and accompanying necessary files to the CVS
-repository.<br>
+repository. You can do this with:<br>
+ <br>
+ <code>cvs add &lt;directory&gt;<br>
+cd &lt;directory&gt;<br>
+cvs add PKGBUILD<br>
+.<br>
+.<br>
+cvs commit</code><br>
+ <br>
</li>
<li>Upload the binary packages using the "tupkg" tool. Run<span
style="font-family: monospace;">:<br>
- </span><code>tupkg
+ </span><code><br>
+tupkg
--host
subzero.elys.com --user &lt;userid&gt; --password &lt;password&gt;
&lt;packagefile.pkg.tar.gz&gt;</code><br>
+ <br>
Note that this is your <span style="font-weight: bold;">AUR login
-password</span> not your CVS password, in case they are different.<br>
+password</span> -- the one you assign when you create your account, not
+your CVS password, in case they are different.<br>
</li>
<li>Once your packages are uploaded successfully, tag the newly
-created package files with the CURRENT tag in cvs.</li>
+created package files with the CURRENT tag in cvs. You can do this with:<br>
+ <code><br>
+cvs tag -cFR CURRENT &lt;newpackagebuilddir&gt;</code> <br>
+ <br>
+ </li>
<li>In 5-10 minutes, the automated script will add them to the AUR
repository. Verify that they appear both in the web interface and
become
-available via pacman -S from the aur repository.</li>
+available via <code>pacman -Sy &lt;package&gt;</code> from the aur
+repository.</li>
<li>Select the newly added or updated package in the AUR web
interface and set yourself as the maintainer.<br>
</li>