summaryrefslogtreecommitdiffstats
path: root/web/template/pkgbase_details.php
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2015-01-09 17:50:15 +0100
committerLukas Fleischer <archlinux@cryptocrack.de>2015-01-09 17:50:39 +0100
commit85b48ceb121ef33ff1114cb1a8b78c197399f92b (patch)
tree6674edc72e675f3d1bd2475d912f17018d3da5cb /web/template/pkgbase_details.php
parent5adb5b8ebdf0e9040c7aa21bdeb62f46e82cf476 (diff)
downloadaurweb-85b48ceb121ef33ff1114cb1a8b78c197399f92b.tar.xz
Link to the cgit log from package details
Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/template/pkgbase_details.php')
-rw-r--r--web/template/pkgbase_details.php5
1 files changed, 4 insertions, 1 deletions
diff --git a/web/template/pkgbase_details.php b/web/template/pkgbase_details.php
index ae363fd..98a7219 100644
--- a/web/template/pkgbase_details.php
+++ b/web/template/pkgbase_details.php
@@ -32,7 +32,10 @@ $pkgs = pkgbase_get_pkgnames($base_id);
<div id="actionlist">
<h4><?= __('Package Actions') ?></h4>
<ul class="small">
- <li><a href="<?= $cgit_uri . $row['Name'] . '.git' ?>/tree/PKGBUILD"><?= __('View PKGBUILD') ?></a></li>
+ <li>
+ <a href="<?= $cgit_uri . $row['Name'] . '.git' ?>/tree/PKGBUILD"><?= __('View PKGBUILD') ?></a> /
+ <a href="<?= $cgit_uri . $row['Name'] . '.git' ?>/log/"><?= __('View Changes') ?></a>
+ </li>
<li><a href="<?= $cgit_uri . $row['Name'] . '.git' ?>/snapshot/master.tar.gz"><?= __('Download snapshot') ?></a></li>
<li><a href="https://wiki.archlinux.org/index.php/Special:Search?search=<?= urlencode($row['Name']) ?>"><?= __('Search wiki') ?></a></li>
<li><span class="flagged"><?php if ($row["OutOfDateTS"] !== NULL) { echo __('Flagged out-of-date')." (${out_of_date_time})"; } ?></span></li>