summaryrefslogtreecommitdiffstats
path: root/web/template/pkg_details.php
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2015-06-20 12:47:23 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2015-06-20 14:29:43 +0200
commit61cdf09cd0581940639d0a6ebf09788f61b93eb9 (patch)
tree39745cf03579b8c2785f05d2ee69b0aade233e6c /web/template/pkg_details.php
parent5d9a80a546265d7c746b236a186a142bc3ecc35e (diff)
downloadaurweb-61cdf09cd0581940639d0a6ebf09788f61b93eb9.tar.xz
Make url and pkgdesc fields optional
The url and pkgdesc PKGBUILD variables are optional, so they should be in the AUR as well. Signed-off-by: Johannes Löthberg <johannes@kyriasis.com> Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'web/template/pkg_details.php')
-rw-r--r--web/template/pkg_details.php8
1 files changed, 8 insertions, 0 deletions
diff --git a/web/template/pkg_details.php b/web/template/pkg_details.php
index 82bc262..1e2b9a5 100644
--- a/web/template/pkg_details.php
+++ b/web/template/pkg_details.php
@@ -189,11 +189,19 @@ $sources = pkg_sources($row["ID"]);
</tr>
<tr>
<th><?= __('Description') . ': ' ?></th>
+<?php if (!empty($row['Description'])): ?>
<td class="wrap"><?= htmlspecialchars($row['Description']); ?></td>
+<?php else: ?>
+ <td class="wrap"><?= __('None') ?></td>
+<?php endif; ?>
</tr>
<tr>
<th><?= __('Upstream URL') . ': ' ?></th>
+<?php if (!empty($row['URL'])): ?>
<td><a href="<?= htmlspecialchars($row['URL'], ENT_QUOTES) ?>" title="<?= __('Visit the website for') . ' ' . htmlspecialchars( $row['Name'])?>"><?= htmlspecialchars($row['URL'], ENT_QUOTES) ?></a></td>
+<?php else: ?>
+ <td class="wrap"><?= __('None') ?></td>
+<?php endif; ?>
</tr>
<?php
if (has_credential(CRED_PKGBASE_SET_KEYWORDS, $maintainers) || count($keywords) > 0):