summaryrefslogtreecommitdiffstats
path: root/web/lib/pkgfuncs.inc.php
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-06-06 10:34:28 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-12-27 12:42:12 +0100
commit74edb6fea9d7e8434d8df00a8eb9dc9703daa19d (patch)
tree5f87103b83b51c4702d2d3aa2afba32f627eea3b /web/lib/pkgfuncs.inc.php
parent943b6bc9769a03e967f08d8b46bd975e2e8d2a20 (diff)
downloadaurweb-74edb6fea9d7e8434d8df00a8eb9dc9703daa19d.tar.xz
Use Git repositories to store packages
* Remove package submission page from the web interface. * Replace PKGBUILD and tarball links with links to cgit. * Remove the "URLPath" field from RPC replies. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/lib/pkgfuncs.inc.php')
-rw-r--r--web/lib/pkgfuncs.inc.php31
1 files changed, 1 insertions, 30 deletions
diff --git a/web/lib/pkgfuncs.inc.php b/web/lib/pkgfuncs.inc.php
index 7e7a98f..0c7f2d9 100644
--- a/web/lib/pkgfuncs.inc.php
+++ b/web/lib/pkgfuncs.inc.php
@@ -184,36 +184,6 @@ function pkg_relations($pkgid) {
}
/**
- * Get the ID of a dependency type given its name
- *
- * @param string $name The name of the dependency type
- *
- * @return int The ID of the dependency type
- */
-function pkg_dependency_type_id_from_name($name) {
- $dbh = DB::connect();
- $q = "SELECT ID FROM DependencyTypes WHERE Name = ";
- $q.= $dbh->quote($name);
- $result = $dbh->query($q);
- return $result->fetch(PDO::FETCH_COLUMN, 0);
-}
-
-/**
- * Get the ID of a relation type given its name
- *
- * @param string $name The name of the relation type
- *
- * @return int The ID of the relation type
- */
-function pkg_relation_type_id_from_name($name) {
- $dbh = DB::connect();
- $q = "SELECT ID FROM RelationTypes WHERE Name = ";
- $q.= $dbh->quote($name);
- $result = $dbh->query($q);
- return $result->fetch(PDO::FETCH_COLUMN, 0);
-}
-
-/**
* Get the HTML code to display a package dependency link
*
* @param string $name The name of the dependency
@@ -779,6 +749,7 @@ function sanitize_ids($ids) {
}
/**
+<<<<<<< HEAD
* Add package information to the database for a specific package
*
* @param int $base_id ID of the package base