summaryrefslogtreecommitdiffstats
path: root/web/lib/pkgbasefuncs.inc.php
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-06-06 10:34:28 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-12-27 12:42:12 +0100
commit74edb6fea9d7e8434d8df00a8eb9dc9703daa19d (patch)
tree5f87103b83b51c4702d2d3aa2afba32f627eea3b /web/lib/pkgbasefuncs.inc.php
parent943b6bc9769a03e967f08d8b46bd975e2e8d2a20 (diff)
downloadaurweb-74edb6fea9d7e8434d8df00a8eb9dc9703daa19d.tar.xz
Use Git repositories to store packages
* Remove package submission page from the web interface. * Replace PKGBUILD and tarball links with links to cgit. * Remove the "URLPath" field from RPC replies. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/lib/pkgbasefuncs.inc.php')
-rw-r--r--web/lib/pkgbasefuncs.inc.php39
1 files changed, 0 insertions, 39 deletions
diff --git a/web/lib/pkgbasefuncs.inc.php b/web/lib/pkgbasefuncs.inc.php
index 708f861..655856b 100644
--- a/web/lib/pkgbasefuncs.inc.php
+++ b/web/lib/pkgbasefuncs.inc.php
@@ -915,45 +915,6 @@ function pkgbase_change_category($base_id) {
}
/**
- * Add package base information to the database
- *
- * @param string $name Name of the new package base
- * @param int $category_id Category for the new package base
- * @param int $uid User ID of the package uploader
- *
- * @return int ID of the new package base
- */
-function pkgbase_create($name, $category_id, $uid) {
- $dbh = DB::connect();
- $q = sprintf("INSERT INTO PackageBases (Name, CategoryID, " .
- "SubmittedTS, ModifiedTS, SubmitterUID, MaintainerUID, " .
- "PackagerUID) VALUES (%s, %d, UNIX_TIMESTAMP(), " .
- "UNIX_TIMESTAMP(), %d, %d, %d)",
- $dbh->quote($name), $category_id, $uid, $uid, $uid);
- $dbh->exec($q);
- return $dbh->lastInsertId();
-}
-
-/**
- * Update package base information for a specific package base
- *
- * @param string $name Name of the updated package base
- * @param int $base_id The package base ID of the affected package
- * @param int $uid User ID of the package uploader
- *
- * @return void
- */
-function pkgbase_update($base_id, $name, $uid) {
- $dbh = DB::connect();
- $q = sprintf("UPDATE PackageBases SET " .
- "Name = %s, ModifiedTS = UNIX_TIMESTAMP(), " .
- "MaintainerUID = %d, PackagerUID = %d, OutOfDateTS = NULL " .
- "WHERE ID = %d",
- $dbh->quote($name), $uid, $uid, $base_id);
- $dbh->exec($q);
-}
-
-/**
* Change the category a package base belongs to
*
* @param int $base_id The package base ID to change the category for