summaryrefslogtreecommitdiffstats
path: root/web/html
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-11-18 23:51:08 +0100
committerLukas Fleischer <archlinux@cryptocrack.de>2014-11-18 23:51:08 +0100
commitaa4acc94050266986c036298268d8b6ee530b5c6 (patch)
tree8740a2e8b0f68ea7c8b7902c39266801181f4f33 /web/html
parent73e7d972776cfc6f5e72575a3bbb34fa2e374fc2 (diff)
downloadaurweb-aa4acc94050266986c036298268d8b6ee530b5c6.tar.xz
Add support for .SRCINFO
pacman officially supports .SRCINFO since commit 6029a77 (makepkg: introduce .SRCINFO files for source packages, 2014-11-08). Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/html')
-rw-r--r--web/html/pkgsubmit.php7
1 files changed, 4 insertions, 3 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index be9220e..d8df290 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -81,7 +81,7 @@ if ($uid):
if (!$error) {
$tar = new Archive_Tar($_FILES['pfile']['tmp_name']);
- /* Extract PKGBUILD and .AURINFO into a string. */
+ /* Extract PKGBUILD and .SRCINFO into a string. */
$pkgbuild_raw = $srcinfo_raw = '';
$dircount = 0;
foreach ($tar->listContent() as $tar_file) {
@@ -94,7 +94,8 @@ if ($uid):
break;
} elseif (substr($tar_file['filename'], -9) == '/PKGBUILD') {
$pkgbuild_raw = $tar->extractInString($tar_file['filename']);
- } elseif (substr($tar_file['filename'], -9) == '/.AURINFO') {
+ } elseif (substr($tar_file['filename'], -9) == '/.AURINFO' ||
+ substr($tar_file['filename'], -9) == '/.SRCINFO') {
$srcinfo_raw = $tar->extractInString($tar_file['filename']);
}
} elseif ($tar_file['typeflag'] == 5) {
@@ -127,7 +128,7 @@ if ($uid):
}
}
- /* Parse .AURINFO and extract meta data. */
+ /* Parse .SRCINFO and extract meta data. */
$pkgbase_info = array();
$pkginfo = array();
$section_info = array();