summaryrefslogtreecommitdiffstats
path: root/web/html
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-04-05 11:47:21 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-04-05 12:21:36 +0200
commit16090496a471f5560e8259ae5c5f4905d067bbb6 (patch)
tree3d0c7185f8fd5e0c7b0ad428631bf978ab2c3135 /web/html
parentd7044eb1ec0cdb54e268369ef30574a4745d3c43 (diff)
downloadaurweb-16090496a471f5560e8259ae5c5f4905d067bbb6.tar.xz
Only parse PKGBUILD when required
Instead of always parsing the PKGBUILD, only invoke the parser when there is no meta data (.AURINFO) available. This speeds up the general case (packages including meta data). Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/html')
-rw-r--r--web/html/pkgsubmit.php4
1 files changed, 2 insertions, 2 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 38c2dde..2432510 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -130,8 +130,6 @@ if ($uid):
}
}
- include('pkgbuild-parser.inc.php');
-
/* Parse .AURINFO and extract meta data. */
$pkgbase_info = array();
$pkginfo = array();
@@ -177,6 +175,8 @@ if ($uid):
}
} else {
/* Use data from the PKGBUILD parser (deprecated!) */
+ include('pkgbuild-parser.inc.php');
+
$pkgbase_info = $new_pkgbuild;
if (!isset($pkgbase_info['pkgbase'])) {
$pkgbase_info['pkgbase'] = $pkgbase_info['pkgname'];