summaryrefslogtreecommitdiffstats
path: root/po
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-07-04 12:10:00 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-07-04 12:16:58 +0200
commit7f29756196ce8743c474bb035d234a72af5381aa (patch)
tree026a8ccd858aea05a808d0c36d7b41bf0d6ed371 /po
parentb113764b0bdf98b7d1d643eb2f55c50988f31deb (diff)
downloadaurweb-7f29756196ce8743c474bb035d234a72af5381aa.tar.xz
Handle plurals in translations
Use ngettext() to handle plurals properly. Also, split pagination captions into two strings. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'po')
-rw-r--r--po/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/po/Makefile b/po/Makefile
index abe02fb..97e1822 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -47,9 +47,9 @@ all: ${MOFILES}
update-pot:
pkgname=AUR; \
pkgver=`sed -n 's/.*"AUR_VERSION", "\(.*\)".*/\1/p' ../web/lib/version.inc.php`; \
- xgettext --default-domain=aur -L php --keyword=__ --no-location \
- --add-comments=TRANSLATORS: --package-name="$$pkgname" \
- --package-version="$$pkgver" \
+ xgettext --default-domain=aur -L php --keyword=__ --keyword=_n:1,2 \
+ --no-location --add-comments=TRANSLATORS: \
+ --package-name="$$pkgname" --package-version="$$pkgver" \
--msgid-bugs-address='${MSGID_BUGS_ADDRESS}' \
--directory ../web --files-from POTFILES -o aur.pot