summaryrefslogtreecommitdiffstats
path: root/po
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-07-27 21:54:38 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-07-27 21:54:38 +0200
commit35e6388fad2226d00a3c82fc63f63373f1c84fad (patch)
tree9e5b5244803b80a2b4999478e62b25a6cc81285f /po
parent9862e533d88e1a63b407b51d1af192169e2366ab (diff)
downloadaurweb-35e6388fad2226d00a3c82fc63f63373f1c84fad.tar.xz
Auto-generate po/POTFILES
Reduce maintenance costs by auto-generating po/POTFILES in the Makefile. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'po')
-rw-r--r--po/Makefile7
-rw-r--r--po/POTFILES58
2 files changed, 5 insertions, 60 deletions
diff --git a/po/Makefile b/po/Makefile
index 97e1822..49eab32 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -44,7 +44,10 @@ all: ${MOFILES}
lang=`echo $@ | sed -e 's/\.po-update$$//'`; \
msgmerge -U --no-location --lang="$$lang" $< aur.pot
-update-pot:
+POTFILES:
+ find ../web -type f -name '*.php' -printf '%P\n' | sort >POTFILES
+
+update-pot: POTFILES
pkgname=AUR; \
pkgver=`sed -n 's/.*"AUR_VERSION", "\(.*\)".*/\1/p' ../web/lib/version.inc.php`; \
xgettext --default-domain=aur -L php --keyword=__ --keyword=_n:1,2 \
@@ -57,7 +60,7 @@ update-po:
${MAKE} ${UPDATEPOFILES}
clean:
- rm -f *.mo *.po\~
+ rm -f *.mo *.po\~ POTFILES
install: all
for l in ${LOCALES}; do mkdir -p ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/; done
diff --git a/po/POTFILES b/po/POTFILES
deleted file mode 100644
index 2b9322b..0000000
--- a/po/POTFILES
+++ /dev/null
@@ -1,58 +0,0 @@
-html/404.php
-html/account.php
-html/addvote.php
-html/home.php
-html/index.php
-html/login.php
-html/logout.php
-html/packages.php
-html/passreset.php
-html/pkgbase.php
-html/pkgdel.php
-html/pkgmerge.php
-html/pkgreq.php
-html/pkgsubmit.php
-html/rpc.php
-html/rss.php
-html/tu.php
-html/voters.php
-lib/acctfuncs.inc.php
-lib/Archive/PEAR5.php
-lib/Archive/PEAR.php
-lib/Archive/Tar.php
-lib/aur.inc.php
-lib/aurjson.class.php
-lib/cachefuncs.inc.php
-lib/DB.class.php
-lib/feedcreator.class.php
-lib/gettext.php
-lib/pkgbasefuncs.inc.php
-lib/pkgfuncs.inc.php
-lib/pkgreqfuncs.inc.php
-lib/routing.inc.php
-lib/stats.inc.php
-lib/streams.php
-lib/translator.inc.php
-lib/version.inc.php
-template/account_delete.php
-template/account_details.php
-template/account_edit_form.php
-template/account_search_results.php
-template/actions_form.php
-template/footer.php
-template/header.php
-template/pkgbase_details.php
-template/pkg_comment_form.php
-template/pkg_comments.php
-template/pkg_details.php
-template/pkgreq_form.php
-template/pkgreq_results.php
-template/pkg_search_form.php
-template/pkg_search_results.php
-template/search_accounts_form.php
-template/stats/general_stats_table.php
-template/stats/updates_table.php
-template/stats/user_table.php
-template/tu_details.php
-template/tu_last_votes_list.php
-template/tu_list.php