summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2015-06-08 14:57:57 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2015-06-08 15:04:13 +0200
commitfcbfaf6a373eefdf84311da0326c1af28eb7edc3 (patch)
tree69b09d678629be042fdcd767c7e11f2efef68286
parentcb00a66855e040209eb393250d69ee17fb523875 (diff)
downloadaurweb-fcbfaf6a373eefdf84311da0326c1af28eb7edc3.tar.xz
git-update: Drop writing git description file
All PKGBUILDs are stored in a single repository now, so there is no use for writing out a description file for the repo anymore. This fixes a bug where pkgdescs containing UTF-8 characters are rejected due to it trying to write the file out using ASCII. Signed-off-by: Johannes Löthberg <johannes@kyriasis.com> Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
-rwxr-xr-xgit-interface/git-update.py6
1 files changed, 0 insertions, 6 deletions
diff --git a/git-interface/git-update.py b/git-interface/git-update.py
index 4177e53..215848e 100755
--- a/git-interface/git-update.py
+++ b/git-interface/git-update.py
@@ -281,9 +281,3 @@ for pkgname in srcinfo.GetPackageNames():
save_srcinfo(srcinfo, db, cur, user)
db.close()
-
-pkglist = list(srcinfo.GetPackageNames())
-if len(pkglist) > 0:
- with open(repo_path + '/description', 'w') as f:
- pkginfo = srcinfo.GetMergedPackage(pkglist[0])
- f.write(pkginfo['pkgdesc'])