summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2015-06-30 20:08:40 +0200
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-30 20:08:40 +0200
commit8832da194a74c1b87a36e7f51960eb1f6e32edea (patch)
treec6d2d54ab3c196066c2ead676b68964eb75245d7
parent5ce710a06aed583a5bffd0ed5956129f63bd31b0 (diff)
downloadaurweb-asciidoc.tar.xz
docs: Add asciidocified translating fileasciidoc
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
-rw-r--r--documentation/Makefile4
-rw-r--r--documentation/translating.txt71
2 files changed, 73 insertions, 2 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 7aa1483..9e76713 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -1,8 +1,8 @@
ASCIIDOC_OPTS = \
-f asciidoc.conf
-HTML_SOURCES = readme hacking
-HTML_PAGES = readme.html hacking.html
+HTML_SOURCES = readme hacking translating
+HTML_PAGES = readme.html hacking.html translating.html
%.html: %.txt asciidoc.conf
asciidoc $(ASCIIDOC_OPTS) --out-file=./$@ $*.txt
diff --git a/documentation/translating.txt b/documentation/translating.txt
new file mode 100644
index 0000000..95aff18
--- /dev/null
+++ b/documentation/translating.txt
@@ -0,0 +1,71 @@
+Translating
+===========
+
+This document describes how to create and maintain aurweb translations. It was
+originally derived from
+<https://wiki.archlinux.org/index.php/aurweb_Translation>.
+
+
+Creating a New Translation
+--------------------------
+
+Before starting, please sign up for a Transifex account and request the
+addition of a new translation team for the aurweb project. Also, please do not
+translate if you are unwilling to maintain or find someone to maintain the
+translation. This is due to the fact that aurweb is a rapidly evolving project
+and there are constantly new strings to be translated. If the translations get
+too out of sync with the released versions, there will be too many untranslated
+strings for the translation to be usable, and it may have to be disabled.
+
+
+1. Check out the aurweb source using git:
+
+ $ git clone git://projects.archlinux.org/aurweb.git aurweb-git
+
+
+2. Go into the 'po/' directory in the aurweb source, and run +msginit(1)+ to
+ create an initial translation file from our translation catalog:
+
+ $ cd aurweb-git
+ $ git checkout master
+ $ git pull
+ $ cd po
+ $ msginit -l <locale> -o <locale>.po -i aur.pot
+
+
+3. Use some editor or a translation helper like poedit to add translations:
+
+ $ poedit <locale>.po
+
+
+4. If you have a working aurweb setup, add a line for the new translation in
+ 'web/lib/translator.inc.php.
+
+
+5. Upload the newly created '.po' file to Tranisfex. If you don't like the web
+ interface you can also use transifex-client to do that (see below).
+
+
+Updating an Existing Translation
+--------------------------------
+
+1. Download current translation files from Transifex. You can also do this
+ using transifex-client which is avaliable through the AUR:
+
+ $ tx pull -a
+
+
+2. Update the existing translation file using an editor or a tool like poedit:
+
+ $ poedit po/<locale>.po
+
+
+3. Push the updated translation file back to Transifex. Using transifex-client,
+ this works as follows:
+
+ $ tx push -r aur.pot -t -l <locale>
+
+
+/////
+vim:set ts=4 sw=4 syntax=asciidoc noet spell spelllang=en_us:
+/////