aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..20b23af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=yalc-git
+pkgver=0.0.1.rc1.r0.gb4d1c2d
+pkgrel=1
+
+pkgdesc='Yet Another LolCat'
+url='https://github.com/yabok/yalc'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+makedepends=('git' 'cmake')
+
+source=('git+https://github.com/yabok/yalc')
+
+sha1sums=('SKIP')
+
+pkgver() {
+ cd yalc
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd yalc
+ make
+}
+
+package() {
+ install -Dm755 yalc/yalc "$pkgdir"/usr/bin/yalc
+}