aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d1f9dc..044f90a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
-# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
-# Contributor: Dmitry Korzhevin <dkorzhevin AT gmail DOT com>
-# Contributor: Mark Foxwell <fastfret79@archlinux.org.uk>
-# Contributor: Licia Todd <tigrmesh at aol dot com>
-# Contributor: Tim Zebulla <amon at faumrahrer dot de>
-# Contributor: Johannes Löthberg <johannes@kyriasis.com>
-
pkgname=weechat-git
-pkgver=git
+pkgver=1.0.rc1.r5.gb62705a
pkgrel=1
+
pkgdesc="Fast, light & extensible IRC client (curses UI)"
-arch=('i686' 'x86_64')
url="http://www.weechat.org/"
+arch=('i686' 'x86_64')
license=('GPL3')
+
depends=('gnutls' 'ncurses' 'libgcrypt')
-makedepends=('git' 'cmake' 'pkgconfig' 'perl' 'python2' 'lua' 'tcl' 'ruby' 'aspell')
optdepends=('perl' 'python2' 'lua' 'tcl' 'ruby' 'aspell')
+makedepends=('git' 'cmake' 'pkgconfig' 'perl' 'python2' 'lua' 'tcl' 'ruby' 'aspell')
+
provides=('weechat')
conflicts=('weechat')
-options=(!libtool)
+
+options=(!libtool debug !makeflags strip)
+
source=("git+https://github.com/weechat/weechat.git")
md5sums=('SKIP')
@@ -29,11 +27,11 @@ pkgver(){
build() {
cd weechat
cmake -DPREFIX=/usr \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so\
- -DENABLE_MAN=ON \
- -DENABLE_DOC=OFF \
- -DWEECHAT_HOME=~/.config/weechat
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so\
+ -DENABLE_MAN=ON \
+ -DENABLE_DOC=OFF \
+ -DWEECHAT_HOME=~/.config/weechat
make
}