aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 26 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d17f53f..505394b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
pkgname=opensmtpd-ldap
pkgver=5.4.2p1
pkgrel=2
+
pkgdesc='Free implementation of the server-side SMTP protocol'
-arch=('i686' 'x86_64')
url='http://www.opensmtpd.org/'
+arch=('i686' 'x86_64')
license=('custom')
+
+options=('emptydirs')
+
depends=('libevent' 'openssl')
+
provides=('smtp-server' 'smtp-forwarder')
conflicts=('smtp-server' 'smtp-forwarder')
+
backup=('etc/smtpd/smtpd.conf' 'etc/smtpd/aliases')
-options=('emptydirs')
+
install=opensmtpd.install
+
source=("http://www.opensmtpd.org/archives/$pkgname-$pkgver.tar.gz"
- 'smtpd.service'
- 'smtpd.socket')
+ 'smtpd.service'
+ 'smtpd.socket')
md5sums=('c76b39a5fcc0ad05eea541e74b16e62a'
- 'a278f272d97a9fe5a8aac784a7c98d67'
- 'c2c01e9ca78df3f65efe40a7c0e17ee0')
+ 'a278f272d97a9fe5a8aac784a7c98d67'
+ 'c2c01e9ca78df3f65efe40a7c0e17ee0')
prepare() {
sed -ri 's,/etc/mail,/etc/smtpd,g' "$pkgname-$pkgver/smtpd/smtpd.conf"
@@ -28,18 +35,18 @@ build() {
# Remove _FORTIFY_SOURCES: FS#38124
export CPPFLAGS=''
./configure \
- --prefix=/usr \
- --sysconfdir=/etc/smtpd \
- --sbindir=/usr/bin \
- --libexecdir=/usr/lib/smtpd \
- --with-maildir=/var/spool/mail \
- --with-privsep-path=/var/empty \
- --with-sock-dir=/run \
- --with-ca-file=/etc/ssl/certs/ca-certificates.crt \
- --with-privsep-user=smtpd \
- --with-queue-user=smtpq \
- --with-experimental-ldap \
- --with-pam
+ --prefix=/usr \
+ --sysconfdir=/etc/smtpd \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/smtpd \
+ --with-maildir=/var/spool/mail \
+ --with-privsep-path=/var/empty \
+ --with-sock-dir=/run \
+ --with-ca-file=/etc/ssl/certs/ca-certificates.crt \
+ --with-privsep-user=smtpd \
+ --with-queue-user=smtpq \
+ --with-experimental-ldap \
+ --with-pam
make
}
@@ -47,7 +54,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
# install license and systemd unit files
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"