aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..24eae0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+
+pkgname=archmap
+pkgver=latest
+pkgrel=1
+
+pkgdesc="Generates a map of Arch Linux users"
+arch=('any')
+url="https://github.com/maelstrom59/ArchMap"
+license=('custom:UNLICENSE')
+
+depends=('python' 'python-geojson')
+makedepends=('git')
+
+install=archmap.install
+source=('archmap::git+https://github.com/maelstrom59/ArchMap.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd archmap
+ git describe --tags | sed 's/^v//; s/-/-r/; s/-/./g'
+}
+
+
+package() {
+ cd archmap
+ install -D archmap.py "$pkgdir/usr/bin/archmap.py"
+
+ install -d "$pkgdir/usr/lib/systemd/system"
+ install -m644 systemd/archmap.{service,timer} "$pkgdir/usr/lib/systemd/system/"
+
+ install -d "$pkgdir/usr/share/doc/archmap"
+ install {README.md,archmap.conf,markers.kml} "$pkgdir/usr/share/doc/archmap"
+
+ install -D -m644 UNLICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}