diff options
author | Johannes Löthberg <johannes@kyriasis.com> | 2014-08-04 18:10:35 +0200 |
---|---|---|
committer | Johannes Löthberg <johannes@kyriasis.com> | 2015-06-01 16:03:41 +0200 |
commit | 40e6313db825721c6c53498242c3b35a0a43b96a (patch) | |
tree | 80d699971016b5a99409566b04d735659e5cf9f3 /PKGBUILD | |
parent | db6a74f678ac7e54cade19d963e732f4564e9571 (diff) | |
download | pkgbuilds-40e6313db825721c6c53498242c3b35a0a43b96a.tar.xz |
Clean up PKGBUILDs
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 21 |
1 files changed, 13 insertions, 8 deletions
@@ -1,33 +1,38 @@ -# Maintainer: Tom <tomgparchaur@gmail.com> -# Contributor: Johannes Löthberg <johannes@kyriasis.com> -# Based on a quantax contribution for irssi-otr - pkgname=xchat-otr pkgver=0.3 pkgrel=2 + pkgdesc="Off-the-Record Messaging (OTR) plugin for the XChat IRC client" -arch=('i686' 'x86_64') url="http://irssi-otr.tuxfamily.org/" +arch=('i686' 'x86_64') license=('GPL2') + depends=('xchat' 'libotr3') makedepends=('cmake' 'pkgconfig' 'python') + source=("http://download.tuxfamily.org/irssiotr/${pkgname}-${pkgver}.tar.gz" - 'http://xchat.org/docs/xchat-plugin.h') + 'http://xchat.org/docs/xchat-plugin.h') md5sums=('49706959af491c721a8a5a62bd224670' - '5ee7da5abedc78a30b90e737370d8f0b') + '5ee7da5abedc78a30b90e737370d8f0b') build() { cd xchat-otr-$pkgver + mkdir -p xchat install -m 644 "$srcdir"/xchat-plugin.h xchat/ + find . -type f -print0 | xargs -0 sed -i 's|libotr|libotr3|g' - cmake -DCMAKE_INSTALL_PREFIX=/usr . -DLIBOTR_LIBRARY=/usr/lib/libotr3.so + + cmake -DCMAKE_INSTALL_PREFIX=/usr . \ + -DLIBOTR_LIBRARY=/usr/lib/libotr3.so make } package(){ cd xchat-otr-$pkgver + make DESTDIR="$pkgdir" install + mv "$pkgdir"/usr/share/doc/irssi-otr "$pkgdir"/usr/share/doc/xchat-otr install -m 644 README.xchat ${pkgdir}/usr/share/doc/xchat-otr } |