aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-02-03 17:01:22 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:39 +0200
commit7685d4e2ddc5886d5500622a21a0a6fce7e7ac57 (patch)
treee5880eca3c4ab2594d4897447e096587ae1dc697 /PKGBUILD
parent8d0b2d6d379075cd8f61550e2ed87951ae423ce2 (diff)
downloadpkgbuilds-7685d4e2ddc5886d5500622a21a0a6fce7e7ac57.tar.xz
weechat-git: Fix pkgver() for rc release tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27e2ea1..5deb710 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=weechat-git
pkgver=git
-pkgrel=1
+pkgrel=2
pkgdesc="Fast, light & extensible IRC client (curses UI)"
arch=('i686' 'x86_64')
url="http://www.weechat.org/"
@@ -23,7 +23,7 @@ md5sums=('SKIP')
pkgver(){
cd weechat
- git describe --tags --long | sed 's/^v//; s/-/-r/; s/-/./g'
+ git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {