aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-10-28 17:47:26 +0000
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:43 +0200
commit2e06093d909d9704b3cac1defdbc390571f804ee (patch)
treef823ab201fcc6d3df970625dc6b123dafa68ba7b /PKGBUILD
parent6142944673afcfe0acc7e2cf98090fd3a8eb9117 (diff)
downloadpkgbuilds-2e06093d909d9704b3cac1defdbc390571f804ee.tar.xz
Revert weechat py3 stuff, doesn't work.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d53e1b0..5c37ea6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('i686' 'x86_64')
license=('GPL3')
depends=('gnutls' 'ncurses-git' 'libgcrypt')
-optdepends=('perl' 'python' 'lua' 'tcl' 'ruby' 'aspell')
+optdepends=('perl' 'python2' 'lua' 'tcl' 'ruby' 'aspell')
makedepends=('git' 'cmake' 'pkgconfig' 'perl' 'python2' 'lua' 'tcl' 'ruby' 'aspell')
provides=('weechat')
@@ -28,9 +28,8 @@ pkgver(){
build() {
cd weechat
cmake -DPREFIX=/usr \
- -DENABLE_PYTHON3=ON \
- -DPYTHON_EXECUTABLE=/usr/bin/python \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.so\
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so\
-DENABLE_MAN=ON \
-DENABLE_DOC=OFF \
-DWEECHAT_HOME=~/.config/weechat