aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-02-06 03:21:06 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-08 12:02:11 +0200
commit022ed9abd19403bfbf89474fbc04d7537779c986 (patch)
tree89ebadd2430da5c53982e623293df1ddc94bba8f /PKGBUILD
downloadpkgbuilds-022ed9abd19403bfbf89474fbc04d7537779c986.tar.xz
Import python-pafy-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..aeb90c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Johannes Löthberg <johannes2kyriasis.com>
+
+pkgname=python-pafy-git
+pkgver=git
+pkgrel=1
+pkgdesc="Python API for YouTube - Download videos and retrieve metadata from YouTube."
+arch=('any')
+url="http://np1.github.io/pafy"
+license=('GPL3')
+depends=('python')
+source=('git+https://github.com/np1/pafy.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd pafy
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd pafy
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim: set ts=2 sts=2 sw=2 noet: