diff options
author | Johannes Löthberg <johannes@kyriasis.com> | 2014-11-16 19:53:52 +0100 |
---|---|---|
committer | Johannes Löthberg <johannes@kyriasis.com> | 2015-06-01 16:03:44 +0200 |
commit | 3402732f1c15010f98b90006f2006573a6b36b6b (patch) | |
tree | f7d7b0f05f1fdca3c9addd6b7f6ec526fc0b998d /PKGBUILD | |
parent | 7d9d3ef004fad53ee3e08d97b2de551b2e034669 (diff) | |
download | pkgbuilds-3402732f1c15010f98b90006f2006573a6b36b6b.tar.xz |
pacman-git: Add Arch pacman.conf and makepkg.conf
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 28 |
1 files changed, 19 insertions, 9 deletions
@@ -4,25 +4,29 @@ pkgrel=1 pkgdesc="A library-based package manager with dependency support. git version." url="http://www.archlinux.org/pacman/" -arch=('i686' 'x86_64') +arch=('x86_64') license=('GPL') depends=('bash' 'curl' 'gpgme' 'libarchive' 'pacman-mirrorlist') -makedepends=('git' 'asciidoc') optdepends=('fakeroot: for makepkg usage as normal user') +makedepends=('git' 'asciidoc') checkdepends=('python2' 'fakechroot') provides=("pacman=$pkgver" 'pacman-contrib' 'libalpm.so') conflicts=('pacman' 'pacman-contrib') -options=('!libtool' '!strip') +options=('strip' 'debug') backup=(etc/pacman.conf etc/makepkg.conf) -source=(git://projects.archlinux.org/pacman.git) +source=(git://projects.archlinux.org/pacman.git + pacman.conf + makepkg.conf) -sha1sums=('SKIP') +sha1sums=('SKIP' + '3c1bddf27602e02fb57801c0ea7313b3869acc92' + 'f2ef3115adaf2aa5c13a1ab7e948c21028451465') pkgver() { cd pacman @@ -55,15 +59,19 @@ package() { cd pacman make DESTDIR="$pkgdir" install + make DESTDIR="$pkgdir" -C contrib install + + # install Arch specific stuff + install -dm755 "$pkgdir"/etc + install -m644 "$srcdir"/pacman.conf "$pkgdir"/etc/ + install -m644 "$srcdir"/makepkg.conf "$pkgdir"/etc/ # set things correctly in the default conf file sed -i "$pkgdir/etc/makepkg.conf" \ - -e "s|@CARCH[@]|$CARCH|g" \ + -e "s|@CARCH[@]|x86_64|g" \ -e "s|@CHOST[@]|x86_64-unknown-linux-gn|g" \ -e "s|@CARCHFLAGS[@]|-march=x86-64 |g" - # contrib - make DESTDIR="$pkgdir" -C contrib install install -Dm644 contrib/PKGBUILD.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/PKGBUILD.vim install -dm755 "$pkgdir"/usr/share/vim/vimfiles/ftdetect @@ -73,9 +81,11 @@ package() { # install completion files rm -r "$pkgdir"/etc/bash_completion.d install -Dm644 contrib/bash_completion "$pkgdir"/usr/share/bash-completion/completions/pacman + install -Dm644 contrib/zsh_completion "$pkgdir"/usr/share/zsh/site-functions/_pacman + for f in makepkg pacman-key; do ln -s pacman "$pkgdir"/usr/share/bash-completion/completions/"$f" done - install -Dm644 contrib/zsh_completion "$pkgdir"/usr/share/zsh/site-functions/_pacman + install -Dm644 contrib/PKGBUILD.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/PKGBUILD.vim } |