aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-08-25 17:57:21 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:42 +0200
commit276910eeb9cd9658e469ab0b9026c3d66a6ebf02 (patch)
treef381ea711d00e536b176085ced6425cb539a6cca /PKGBUILD
parent51b330497d32fdec4f981b02f7166464bf13ba34 (diff)
downloadpkgbuilds-276910eeb9cd9658e469ab0b9026c3d66a6ebf02.tar.xz
opensmtpd-ldap: don't hardcode pkgnameopensmtpd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c30ffa9..f68c29c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ conflicts=('smtp-server' 'smtp-forwarder')
backup=('etc/smtpd/smtpd.conf' 'etc/smtpd/aliases')
install=opensmtpd.install
-source=("http://www.opensmtpd.org/archives/$pkgname-$pkgver.tar.gz"
+source=("http://www.opensmtpd.org/archives/opensmtpd-$pkgver.tar.gz"
'smtpd.service'
'smtpd.socket')
@@ -26,11 +26,11 @@ md5sums=('c76b39a5fcc0ad05eea541e74b16e62a'
'c2c01e9ca78df3f65efe40a7c0e17ee0')
prepare() {
- sed -ri 's,/etc/mail,/etc/smtpd,g' "$pkgname-$pkgver/smtpd/smtpd.conf"
+ sed -ri 's,/etc/mail,/etc/smtpd,g' "opensmtpd-$pkgver/smtpd/smtpd.conf"
}
build() {
- cd "$pkgname-$pkgver"
+ cd opensmtpd-$pkgver
# Remove _FORTIFY_SOURCES: FS#38124
export CPPFLAGS=''
@@ -52,7 +52,7 @@ build() {
}
package() {
- cd "$pkgname-$pkgver"
+ cd opensmtpd-$pkgver
make DESTDIR="$pkgdir" install