aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-02-16 02:32:57 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:25:12 +0200
commit583b49f804923e9db081b9cc932a3f8b7ad3471a (patch)
tree3424c62c25cf01a3a812327e0b413f0f3a47341d /PKGBUILD
parent498f6ee739a909f24b1aec3c65b87da8b2ff9f67 (diff)
downloadpkgbuilds-583b49f804923e9db081b9cc932a3f8b7ad3471a.tar.xz
Dump...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 20 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63206d7..1051cc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,37 @@
# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
pkgname=openhexagon
-pkgver=1.92
-pkgrel=3
+pkgver=2.0RC1
+pkgrel=1
pkgdesc="C++ open source clone of Super Hexagon. (binary)"
arch=('i686' 'x86_64')
url="http://vittorioromeo.info/projects.html"
options=(!strip)
license=('custom:AFL')
-depends=('openal')
-source=('http://vittorioromeo.info/Downloads/OpenHexagon/Linux/OpenHexagonV1.92.tar.gz'
- 'https://raw.github.com/SuperV1234/SSVOpenHexagon/master/LICENSE')
-md5sums=('bda07a9d91a9dd8538d9a7a26562de69'
- '808282b4d6cf58dacf16fae6068bd030')
+depends=('lua51' 'gcc-libs-multilib' 'mesa' 'libjpeg-turbo' 'sfml')
+source=(OpenHexagon.tar::'http://vittorioromeo.info/Misc/Temp/OpenHexagon2.0-RC1.xz'
+ 'https://raw.github.com/SuperV1234/SSVOpenHexagon/master/LICENSE' OpenHexagon)
+md5sums=('758df0cb21c5a565f4039c5e0bc6b2c6'
+ '2002c3e1decad54ffe535efef6723a5c'
+ 'cedfdc5a1bfdf70f730f06466a8d28c5')
+prepare() {
+ cd testInstall2
+ (cd x86
+ find -not -type d -not -name "SSVOpenHexagon" -not -name "libsfml*" -exec rm {} +)
+ find -exec chmod 755 {} +
+ sed -i 's|\./x86|/opt/openhexagon2.0-RC1/x86|g' OpenHexagon
+ mv ../OpenHexagon .
+}
package() {
- install -d "$pkgdir"/opt/OpenHexagon1.92
- cp -r OpenHexagon1.92 "$pkgdir"/opt/
+ install -d "$pkgdir"/opt/openhexagon2.0-RC1
+ cp -r testInstall2/* "$pkgdir"/opt/openhexagon2.0-RC1
install -d "$pkgdir"/usr/bin
- ln -s /opt/OpenHexagon1.92/OpenHexagon "$pkgdir"/usr/bin/openhexagon
+ ln -s /opt/openhexagon2.0-RC1/OpenHexagon "$pkgdir"/usr/bin/openhexagon
# Need world writeable Profiles for creating profiles and config for... config
- chmod 777 "$pkgdir"/opt/OpenHexagon1.92/{Profiles,config.json}
+ chmod 777 "$pkgdir"/opt/openhexagon2.0-RC1/{Profiles,config.json}
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim: set ts=4 sw=4 noet: