diff options
author | Johannes Löthberg <johannes@kyriasis.com> | 2014-08-04 18:22:39 +0200 |
---|---|---|
committer | Johannes Löthberg <johannes@kyriasis.com> | 2015-06-01 16:03:41 +0200 |
commit | d9eecabe761b8331a416d65db8cbf546bcb9a274 (patch) | |
tree | 4de743d4f9ab072311cd0dfd1fe23d8be10cece2 /PKGBUILD | |
parent | 18940284076403e86691e658502f7a715743f335 (diff) | |
download | pkgbuilds-d9eecabe761b8331a416d65db8cbf546bcb9a274.tar.xz |
mutt-kz-git: enable gss
Also some cleaning up
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 79 |
1 files changed, 35 insertions, 44 deletions
@@ -1,70 +1,61 @@ -# Maintainer: Johannes Löthberg <johannes@kyriasis.com> -# Contributor: neersighted <n@neersighted.com> -# Contributor: boyska <piuttosto@logorroici.org> - pkgname=mutt-kz-git -pkgver=git +pkgver=1.5.22.1.rc1.r32.g738df8f pkgrel=1 pkgdesc='Small but powerful text-based mail client' -arch=('i686' 'x86_64') url='https://github.com/karelzak/mutt-kz' +arch=('i686' 'x86_64') license=('GPL') +depends=('gdbm' 'gpgme' 'openssl>=0.9.8e' 'libsasl' + 'mime-types' 'ncurses' 'notmuch' 'zlib') +makedepends=('git' 'gnupg' 'libxslt') + +conflicts=('mutt') +provides=('mutt') + source=('git+https://github.com/karelzak/mutt-kz.git' 'xdg.patch' 'trash.patch::https://www.cs.oberlin.edu/~kuperman/help/code/patch-1.5.20.bk.trash_folder-purge_message.1.txt') sha1sums=('SKIP' '8cbae5a7ade3812cbdcb8a8dfabb29b042b7296a' 'b63fe4e7ea2a113819558862be1387364ec24213') -depends=('gdbm' 'gpgme' 'openssl>=0.9.8e' 'libsasl' 'mime-types' 'ncurses' 'notmuch' 'zlib') -makedepends=('git' 'gnupg' 'libxslt') - -conflicts=('mutt') -provides=('mutt') - pkgver() { - cd mutt-kz - git describe --always | sed 's/^v//;s/-/./g' + cd mutt-kz + git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g' } prepare() { - cd mutt-kz + cd mutt-kz - # Apply patches. - patch -p1 < "$srcdir/trash.patch" - patch -p1 < "$srcdir/xdg.patch" + patch -p1 < "$srcdir/trash.patch" + patch -p1 < "$srcdir/xdg.patch" } build() { - cd mutt-kz - - # Configure the build. - ./prepare \ - --prefix=/usr \ - --sysconfdir=/etc \ - --enable-debug \ - --enable-gpgme \ - --enable-hcache \ - --enable-imap \ - --enable-notmuch \ - --enable-pgp \ - --enable-pop \ - --enable-smtp \ - --with-idn \ - --with-sasl \ - --with-ssl=/usr - - # Build it! - make + cd mutt-kz + + ./prepare \ + --prefix=/usr \ + --sysconfdir=/etc \ + --enable-debug \ + --enable-gpgme \ + --enable-hcache \ + --enable-imap \ + --enable-notmuch \ + --enable-pgp \ + --enable-pop \ + --enable-smtp \ + --with-idn \ + --with-sasl \ + --with-gss \ + --with-ssl=/usr + make } package() { - cd mutt-kz - - # Install the program. - make DESTDIR="$pkgdir" install + cd mutt-kz - # Provided by the mime-types package. - rm "$pkgdir/etc/mime.types" + make DESTDIR="$pkgdir" install + rm "$pkgdir/etc/mime.types" } |