aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-03-11 00:51:56 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:40 +0200
commitb008cf5a675e8c21e2b2e21780716675e5c8823d (patch)
tree21eaaa6939c5a1922ae5872fba84674308d15d0b /PKGBUILD
downloadpkgbuilds-b008cf5a675e8c21e2b2e21780716675e5c8823d.tar.xz
Replace mutt-patched with mutt-kz-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..12326c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: neersighted <n@neersighted.com>
+# Contributor: boyska <piuttosto@logorroici.org>
+
+pkgname=mutt-kz-git
+pkgver=1.5.22.1.rc1.23.g51e74b7
+pkgrel=1
+pkgdesc='Small but powerful text-based mail client (experimental fork) (development version)'
+url='https://github.com/karelzak/mutt-kz'
+license=('GPL')
+source=('git://github.com/karelzak/mutt-kz.git' 'xdg.patch'
+ 'trash.patch::https://www.cs.oberlin.edu/~kuperman/help/code/patch-1.5.20.bk.trash_folder-purge_message.1.txt')
+sha1sums=('SKIP'
+ '8cbae5a7ade3812cbdcb8a8dfabb29b042b7296a'
+ 'b63fe4e7ea2a113819558862be1387364ec24213')
+arch=('i686' 'x86_64')
+depends=('gdbm' 'gpgme' 'openssl>=0.9.8e' 'libsasl' 'mime-types' 'ncurses' 'notmuch' 'zlib')
+makedepends=('git' 'gnupg' 'libxslt')
+conflicts=('mutt')
+provides=('mutt')
+
+pkgver() {
+ cd mutt-kz
+ git describe --always | sed 's/^v//;s/-/./g'
+}
+
+prepare() {
+ cd mutt-kz
+
+ # Apply patches.
+ patch -p1 < "$srcdir/trash.patch"
+ patch -p1 < "$srcdir/xdg.patch"
+}
+
+build() {
+ cd mutt-kz
+
+ # Configure the build.
+ ./prepare \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-debug \
+ --enable-gpgme \
+ --enable-hcache \
+ --enable-imap \
+ --enable-notmuch \
+ --enable-pgp \
+ --enable-pop \
+ --enable-smtp \
+ --with-idn \
+ --with-sasl \
+ --with-ssl=/usr
+
+ # Build it!
+ make
+}
+
+package() {
+ cd mutt-kz
+
+ # Install the program.
+ make DESTDIR="$pkgdir" install
+
+ # Provided by the mime-types package.
+ rm "$pkgdir/etc/mime.types"
+}
+
+# vim: set ts=2 sw=2 et: