aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-11-11 19:33:37 +0000
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:44 +0200
commit9239bed1779b65db5e2431230bb233d87b2e9e1a (patch)
tree5f0f57e63ba0c4e0014de27c6c04645dd1238b7b /PKGBUILD
downloadpkgbuilds-9239bed1779b65db5e2431230bb233d87b2e9e1a.tar.xz
dunst-git: import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..da89594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=dunst-git
+pkgver=1.0.0.616.9117df5
+pkgrel=1
+
+pkgdesc="Customizable and lightweight notification-daemon"
+url="http://www.knopwob.org/dunst"
+arch=('i686' 'x86_64')
+license=('BSD')
+
+depends=('libxinerama' 'libxss' 'pango' 'libnotify')
+makedepends=('git' 'perl')
+
+provides=('dunst' 'notification-daemon')
+conflicts=('dunst')
+
+source=('git://github.com/knopwob/dunst.git')
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dunst
+ git describe | sed -r 's/^v//; s/([^-]*-g)/r\1/; s/znc-//; s/-/./g'
+}
+
+build() {
+ cd dunst
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 dunstify
+}
+
+package() {
+ cd dunst
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+
+ install -Dm755 dunstify "$pkgdir"/usr/bin/dunstify
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}