aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2015-05-07 15:46:11 +0200
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:46 +0200
commit906434b37d067f984f4701b5e432b8e61e7170c4 (patch)
tree91c9700e92ab97cc271fce5ee1645798636f569e /PKGBUILD
downloadpkgbuilds-906434b37d067f984f4701b5e432b8e61e7170c4.tar.xz
bemenu-git: import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..d2df7cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+pkgname=bemenu-git
+pkgver=r201.c2eabf2
+pkgrel=1
+
+pkgdesc='Dynamic menu library and client program inspired by dmenu'
+url='https://github.com/Cloudef/bemenu'
+license=('GPL3' 'LGPL3')
+arch=('i686' 'x86_64')
+
+depends=('pango')
+makedepends=('git' 'cmake' 'libxkbcommon' 'libxinerama' 'wayland')
+optdepends=('wayland: For the wayland backend.'
+ 'libxkbcommon: For the wayland backend.'
+ 'libxinerama: For the x11 backend.'
+ 'ncurses: For the curses backend.')
+
+provides=('bemenu')
+conflicts=('bemenu')
+
+source=('git+https://github.com/Cloudef/bemenu')
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd bemenu
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+}
+
+build() {
+ cd bemenu
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+check() {
+ cd bemenu
+ make test
+}
+
+package() {
+ cd bemenu
+ make DESTDIR="$pkgdir" install
+}