summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 16 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index ee26f3bb..2e7f433f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,9 +88,14 @@ AC_ARG_WITH(db-ext,
AS_HELP_STRING([--with-db-ext=ext], [set the file extension used by the database]),
[DBEXT=$withval], [DBEXT=.db.tar.gz])
-# Help line for libdownload/libfetch
+# Help line for buildscript filename
+AC_ARG_WITH(buildscript,
+ AS_HELP_STRING([--with-buildscript=name], [set the build script name used by makepkg]),
+ [BUILDSCRIPT=$withval], [BUILDSCRIPT=PKGBUILD])
+
+# Help line for libfetch
AC_ARG_ENABLE(internal-download,
- AS_HELP_STRING([--disable-internal-download], [do not build with libdownload/libfetch support]),
+ AS_HELP_STRING([--disable-internal-download], [do not build with libfetch support]),
[internaldownload=$enableval], [internaldownload=yes])
# Help line for documentation
@@ -131,17 +136,14 @@ AM_GNU_GETTEXT_VERSION(0.13.1)
AC_CHECK_LIB([archive], [archive_read_data], ,
AC_MSG_ERROR([libarchive is needed to compile pacman!]))
-# Enable or disable usage of libdownload/libfetch
-# - this is a nested check- first see if we need a library, if we do then
-# check for libdownload first, then fallback to libfetch, then die
-AC_MSG_CHECKING(whether to link with download library)
+# Enable or disable usage of libfetch
+AC_MSG_CHECKING(whether to link with libfetch)
if test "x$internaldownload" = "xyes" ; then
AC_MSG_RESULT(yes)
AC_DEFINE([INTERNAL_DOWNLOAD], , [Use internal download library])
# Check for a download library if it was actually requested
- AC_CHECK_LIB([download], [downloadParseURL], ,
- AC_CHECK_LIB([fetch], [fetchParseURL], ,
- AC_MSG_ERROR([libdownload or libfetch are needed to compile with internal download support])) )
+ AC_CHECK_LIB([fetch], [fetchParseURL], ,
+ AC_MSG_ERROR([libfetch is needed to compile with internal download support]) )
else
AC_MSG_RESULT(no)
fi
@@ -314,6 +316,9 @@ AC_DEFINE_UNQUOTED([SRCEXT], "$SRCEXT", [The file extension used by pacman sourc
# Set database file extension
AC_SUBST(DBEXT)
AC_DEFINE_UNQUOTED([DBEXT], "$DBEXT", [The file extension used by pacman databases])
+# Set makepkg build script name
+AC_SUBST(BUILDSCRIPT)
+AC_DEFINE_UNQUOTED([BUILDSCRIPT], "$BUILDSCRIPT", [The build script name used by makepkg])
# Configuration files
AC_CONFIG_FILES([
@@ -326,6 +331,7 @@ doc/Makefile
etc/Makefile
po/Makefile.in
pactest/Makefile
+pactest/tests/Makefile
contrib/Makefile
Makefile
])
@@ -361,6 +367,7 @@ ${PACKAGE_NAME}:
package extension : ${PKGEXT}
source pkg extension : ${SRCEXT}
database extension : ${DBEXT}
+ build script name : ${BUILDSCRIPT}
Compilation options:
Run make in doc/ dir : ${wantdoc}